After CW MCU 10.6 update, MSCAN doesn't work

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

After CW MCU 10.6 update, MSCAN doesn't work

1,721 Views
hanchengyang
Contributor II

With the same code and the same settings, after update the codewarroir, MSCAN can't receive or transmit any frame.

In the SourceTree i saw the modification in cpu_config.h like:

 

Loss of clock reset:enable ---->disable

#define CPU_DEFAULT_FEI_ICS_C4 0x80 ---->0x00

......

 

Hereby i upload the two project before and after the update.

 

Thanks

Original Attachment has been moved to: before_update.7z.zip

Original Attachment has been moved to: after_update.7z.zip

0 Kudos
10 Replies

1,390 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello ,

Please tell me you update which patch on CodeWarrior .

BR

Alice

0 Kudos

1,390 Views
hanchengyang
Contributor II

Sorry i didn't notice that... :smileysad:

The old version is: CodeWarrior for MCU

Version: 10.6

Build Id:140329

and i just updated all that showed in "Available Updates".

2015-04-15 6:05 GMT+02:00 Alice_Yang <admin@community.freescale.com>:

<https://community.freescale.com/>

After CW MCU 10.6 update, MSCAN doesn't work

reply from Alice_Yang

<https://community.freescale.com/people/Alice_Yang?et=watches.email.thread>

in Processor Expert Software - View the full discussion

<https://community.freescale.com/message/505314?et=watches.email.thread#505314>

0 Kudos

1,390 Views
marek_neuzil
NXP Employee
NXP Employee

Hello,

I have analyzed and compared these two project but I cannot see any issue. The CPU_DEFAULT_FEI_ICS_C4 constant is not used in your application. There are defined following constants for the clock configuration 0 (FEI mode) that are used but these constants are same in both projects.

/* Clock configuration 0 */
#define CPU_ICS_MODE_CONFIG_0                              (CPU_ICS_MODE_FEI | CPU_CLOCK_SLOW_MASK) /* Clock generator mode */
#define CPU_ICS_C1_CONFIG_0                                0x06U /* ICS_C1 */
#define CPU_ICS_C2_CONFIG_0                                0x20U /* ICS_C2 */
#define CPU_ICS_C4_CONFIG_0                                0x00U /* ICS_C4 */
#define CPU_ICS_S_CONFIG_0                                 0x00U /* ICS_S */
#define CPU_OSC_CR_CONFIG_0                                0x00U /* OSC_CR */
#define CPU_SIM_CLKDIV_CONFIG_0                            0x00UL /* SIM_CLKDIV */

I have noticed that your project is created in the Linked mode, i.e. static source code files are linked from libraries (these files are not included in the project). if you did any change in these source code files the change (modification) could be replaced by a CW MCU 10.6 update and it could be the cause of your issue.

Best Regards,

Marek Neuzil


0 Kudos

1,390 Views
hanchengyang
Contributor II

Hello

But I have never changed default settings. In fact I cannot make CAN BUS

work no matter how, after updating. CAN seems not activated.

Marek Neuzil <admin@community.freescale.com>于2015年4月22日星期三写道:

<https://community.freescale.com/>

After CW MCU 10.6 update, MSCAN doesn't work

reply from Marek Neuzil

<https://community.freescale.com/people/marek_neuzil?et=watches.email.thread>

in Processor Expert Software - View the full discussion

<https://community.freescale.com/message/508078?et=watches.email.thread#508078>

0 Kudos

1,390 Views
marek_neuzil
NXP Employee
NXP Employee

Hello,

Which target board are you using? What CAN device is used for the communication (e.g. a CAN analyzer or the same target board with this application). This application must be run on a target board and the pins of the CAN device must be connected to a CAN bus.

If I have the same target board I will try to run the application and debug it.

Best Regards,

Marek Neuzil

0 Kudos

1,390 Views
hanchengyang
Contributor II

Thanks for your reply,

I am using KE06Z128 connected to CANalyzer.

Best regards

2015-04-22 13:46 GMT+02:00 Marek Neuzil <admin@community.freescale.com>:

<https://community.freescale.com/>

After CW MCU 10.6 update, MSCAN doesn't work

reply from Marek Neuzil

<https://community.freescale.com/people/marek_neuzil?et=watches.email.thread>

in Processor Expert Software - View the full discussion

<https://community.freescale.com/message/508203?et=watches.email.thread#508203>

0 Kudos

1,390 Views
carloshass
Contributor II

Hello!

some new about this problem?

I'm using CW 10.6, with MSCAN_KEA128 example, and CAN is not working.

0 Kudos

1,390 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello ,

I checked it on my side , it also like yours :

/* ICS_C4: LOLIE=0,CME=0 */

#define CPU_DEFAULT_FEI_ICS_C4                             0x00U     /* ICS_C4 value in FEI default state */

And if you change the "0x00u" to "0x80" , does it can work well ?

0 Kudos

1,391 Views
hanchengyang
Contributor II

I can't do so, because the code will generate every time I compile it, even

I have chosen "dont generate code" for CPU.

2015-04-15 12:04 GMT+02:00 Alice_Yang <admin@community.freescale.com>:

<https://community.freescale.com/>

After CW MCU 10.6 update, MSCAN doesn't work

reply from Alice_Yang

<https://community.freescale.com/people/Alice_Yang?et=watches.email.thread>

in Processor Expert Software - View the full discussion

<https://community.freescale.com/message/505468?et=watches.email.thread#505468>

0 Kudos

1,391 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello,

Please freeze the PE code , do like this :

1.png

2.png

BR

Alice

0 Kudos