EVM (KITPF8200FRDMEVM) output issue

cancel
Showing results for 
Search instead for 
Did you mean: 

EVM (KITPF8200FRDMEVM) output issue

1,520 Views
wsjeong
Contributor I

Hello.

I am testing with EVM (KITPF8200FRDMEVM), the waveform of the output voltage is strange.

1) Normal case: Output at normal voltage
2) Abnormal: Output back to normal voltage-> Medium-> Fall back to 0 V with normal voltage output
What are the causes of these symptoms?

Is there something wrong with the TBB file?
Please check the attached file.
Best Regards
Labels (1)
0 Kudos
11 Replies

1,325 Views
guoweisun
NXP TechSupport
NXP TechSupport

Hi

For your case:

1: Do you have successfully upload this script to programmer tool?

2: Do you have a look after connect with load on SW2/3 LDO1?

0 Kudos

1,325 Views
wsjeong
Contributor I

Hi.

1: Do you have successfully upload this script to programmer tool?  : YES

2: Do you have a look after connect with load on SW2/3 LDO1? : NO. But, in both cases (normal and abnormal) the measurement environment was the same.

0 Kudos

1,325 Views
guoweisun
NXP TechSupport
NXP TechSupport

For your failure script please add same small load on channels SW2/3/LDO1.

Do you have monitor on input side?

0 Kudos

1,325 Views
wsjeong
Contributor I

1. It was not related to the load.

2.There was no problem with the input voltage.

3. OTP_LDO1_SEQ

If the OTP_LDO1_SEQ value is between 232 and 254, no problem.
The problem occurs when OTP_LDO1_SEQ is less than or equal to 230.
How is it related to the LDO1 sequence?
0 Kudos

1,326 Views
guoweisun
NXP TechSupport
NXP TechSupport

Do you ever use your script3 to do OTP then test again to verify?

0 Kudos

1,325 Views
wsjeong
Contributor I

When OTP_LDO1_SEQ is less than or equal to 230,whether SW2/3 abnormal? : YES

Do you ever use your script3 to do OTP then test again to verify? : It was not tested in OTP mode.

In addition, the following was confirmed:
If only the LDO SEQ of one of the 4 LDOs is 232-254, no problem.
(LDO1 SEQ : 38 / LDO2 SEQ : OFF / LDO3 SEQ : 42 / LDO4 SEQ : 232  => no problem)
0 Kudos

1,325 Views
guoweisun
NXP TechSupport
NXP TechSupport

If this is real in TBB mode,please verify it in OTP mode again.

0 Kudos

1,325 Views
wsjeong
Contributor I

Does it mean to burn in OTP mode in EVM? If I burn into the EVM once in OTP mode, can I not burn in OTP mode again after that?

0 Kudos

1,325 Views
guoweisun
NXP TechSupport
NXP TechSupport

HI

KITPF8200FRDMEVM can't  do OTP,you need programmer socket with blank PF8200 version device below link:

PF8200/PF8100 Programming Board | NXP 

0 Kudos

1,325 Views
wsjeong
Contributor I
There is currently no programming board, so I can't test it.
How can you explain this situation if the power issue does not occur when PMIC is burned in OTP mode on the programming board?
Or what if the power issue occurs in OTP mode? Is there a problem with the EVM?
0 Kudos

1,325 Views
jinyuzhang
NXP Employee
NXP Employee

Hi WS 

    Do you have plan to use Blank PF8100 on your board ?

    If you just emulate and test before use the OTP part,  I recommend you just need to focus on the things happen after PWRON HIgh, if use OTP device, the thing will be same to the POWRON high after TBB write, we don't need to care about the TBB write process.

    Do you mind to provide your project information?

BRs

jinyu 

0 Kudos