OpenMP library in SDK 1.7

cancel
Showing results for 
Search instead for 
Did you mean: 

OpenMP library in SDK 1.7

288 Views
sharathchandra
Contributor II

Hi,

I am using SDK 1.7 for P4080DS board. On the board, I could see GCC installed but without OpenMP library.

How do I enable openmp library in SDK and build it?

I tried the following, but it did not work,

1.  CORE_IMAGE_EXTRA_INSTALL += "libgomp libgomp-dev libgomp-staticdev"  at the end of local.conf under directory build_p4080ds_release/conf.

2.  I removed all the occurences of --disable-libgomp  from the poky/meta/recipes-devtools/gcc/gcc-4.8.inc header.

Before doing the above changes, I tried to clean under the build directory using bitbake -c clean -f, but it appears it does not clean everything.

So I deleted the build directory build_p4080ds_release and created again, add the above changes and built everything. But this also did not work.

I am new to Yocto environment, could anyone please suggest what to do?

Thanks,

Sharath Chandra

Labels (1)
0 Kudos
2 Replies

87 Views
lunminliang
NXP Employee
NXP Employee

Hello Sharath Chandra,

Is the compile-time flag -fopenmp specified?

Regards

Lunmin

0 Kudos

87 Views
sharathchandra
Contributor II

Hi LunMin,

I tried to give -fopenmp option, but it does not take and gives the following error:

     gcc: error: libgomp.spec: No such file or directory

Then I found that, no libgomp libraries were present on the board.

The library might not have got included while adding GCC to file system when building SDK.

How do I edit the recipes to include libgomp?

Thanks,

Sharath Chandra

0 Kudos