Unable to mount eMMC on T1024RDB.

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Unable to mount eMMC on T1024RDB.

ソリューションへジャンプ
4,181件の閲覧回数
Kasturi_s
Contributor III

Hello Team,

I am using a T1024RDB processor for our project. I can create partitions on eMMC successfully, but I am unable to mount them to the user space.

The partition table looks as,

*********************************************************************

Disk /dev/mmcblk0: 13.8 GiB, 14763950080 bytes, 28835840 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x17be4acf

Device Boot Start End Sectors Size Id Type
/dev/mmcblk0p1 2048 3048 1001 500.5K c W95 FAT32 (LBA)
/dev/mmcblk0p2 4096 5098 1003 501.5K 83 Linux

Command (m for help):

*********************************************************************

Below is the error observed when trying to mount.

**********************************************************************

root@t1024rdb:~# mount /dev/mmcblk0p1 /mnt/temp
mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0p1,
missing codepage or helper program, or other error

In some cases useful info is found in Syslog - try
dmesg | tail or so.

**********************************************************************

 

Request your support at the earliest.

 

Thanks in advance,

Kasturi.

0 件の賞賛
返信
1 解決策
4,154件の閲覧回数
yipingwang
NXP TechSupport
NXP TechSupport

Please try command 

# mount -t vfat /dev/mmcblk0p1 /mnt/temp

If it still doesn't work, please try the following command.

# mkfs.vfat /dev/mmcblk0p1

# mount -t vfat /dev/mmcblk0p1 /mnt/temp

元の投稿で解決策を見る

0 件の賞賛
返信
2 返答(返信)
4,155件の閲覧回数
yipingwang
NXP TechSupport
NXP TechSupport

Please try command 

# mount -t vfat /dev/mmcblk0p1 /mnt/temp

If it still doesn't work, please try the following command.

# mkfs.vfat /dev/mmcblk0p1

# mount -t vfat /dev/mmcblk0p1 /mnt/temp

0 件の賞賛
返信
4,148件の閲覧回数
Kasturi_s
Contributor III

Thank you for the reply yipingwang,

I tried the commands you suggested, but still, it did not work for me.

Below is the log for your reference.

--------------------------------------------------------------------

root@t1024rdb:~# mkfs.vfat /dev/mmcblk0p1
root@t1024rdb:~# mount -t vfat /dev/mmcblk0p1 /mnt/
[ 116.031339] FAT-fs (mmcblk0p1): codepage cp437 not found
mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0p1,
missing codepage or helper program, or other error

In some cases useful info is found in Syslog - try
dmesg | tail or so.
root@t1024rdb:~#

----------------------------------------------------------------------------

 

It says codepage not found, But it is enabled in the kernel menuconfig, attached is the screenshot for your reference.

 

Thank you,

Kasturi.

 

 

0 件の賞賛
返信