Parallel CMOS camera doesn't work in imx6qp

cancel
Showing results for 
Search instead for 
Did you mean: 

Parallel CMOS camera doesn't work in imx6qp

63 Views
Contributor III

Hi,

My linux os version is 4.14.98_2.0.0. I am trying to operate CMOS camera module connected to CSI0_DAT12 ~ CSI0_DAT19. I have modified camera sensor driver and check camera display but it didn't work.

I have checked it with gst_streamer and test command is below:

gst-launch-1.0 v4l2src device=/dev/video0 ! 'video/x-raw,width=800,height=600' ! imxv4l2sink

after the above command, kernel hangs up and output ioctl command with infinite loop.

In MVC:mxc_v4l_ioctl

In MVC: mxc_v5l_do_ioctl c0485619

     case VIDIOC_ENUMSTD

Could you please let me know why the above kernel log display and camera work?

 

0 Kudos
4 Replies

58 Views
NXP TechSupport
NXP TechSupport

Hi yibhan

 

before trying gstreamer one can try more simple camera unit tests

https://source.codeaurora.org/external/imx/imx-test/tree/test/mxc_v4l2_test?h=imx_5.4.24_2.1.0

described in Chapter 10 Unit Tests  i.MX Linux Reference Manual​

 

Best regards
igor

0 Kudos

48 Views
Contributor III

Hi, 

Thank you for supporting.

I have used mxc_v4l2_output.out under /unit_tests.

error message is below:

ERROR: v4l2_capture: mxc_v4l_read timeout counter 0

and the used command is below:

./mxc_v4l2_still.out -w 720 -h 576 -f YUV420

 

I am not sure where I should start at for debugging.

 

0 Kudos

45 Views
NXP TechSupport
NXP TechSupport

one can start debugging with checking signals with oscilloscope.

 

Best regards
igor

 

0 Kudos

38 Views
Contributor III

Hi,

 

Thank you for answering.

I have checked the signals from camera sensor, and they work.

0 Kudos