Imx27-ADS Problem setting up TFTP

cancel
Showing results for 
Search instead for 
Did you mean: 

Imx27-ADS Problem setting up TFTP

2,054 Views
Aleem
Contributor I
Dear All,

I am using IMX27 ADS eval board. I have problem downloading file from network.

I have set the redboot netork parameters as follows.
-----------------------------------------------------------------------
RedBoot>
RedBoot> fconfig -l
Run script at boot: false
Use BOOTP for network configuration: false
Gateway IP address: 192.168.1.1
Local IP address: 192.168.1.126
Local IP address mask: 255.255.255.0
Default server IP address: 192.168.1.141
Board specifics: 0
Console baud rate: 115200
Set eth0 network hardware address [MAC]: false
Set FEC network hardware address [MAC]: false
GDB connection port: 9000
Force console for special debug messages: false
Network debug at boot time: false
Default network device: cs8900a_eth0
RedBoot>
_________________________________________
I am using cross cable and i am not able to ping to the board.< board IP address being (192.168.1.126 ) >
and Server IP address being < 192.168.1.141 >.

Any idea where i am doing wrong. Please guide in this regards.

Thanks in advance.
Aleem


0 Kudos
2 Replies

435 Views
admin
Specialist II
Hi,
Just some few things to check....
Not sure about what I will say, but I saw you don't fix a Mac address for your ethernet on the board... I believe the ping, at first, send an arp packet to get ip address from mac address...
The second point is, I don't know what about redBoot but, under u-boot, I can ping my computer from the board, but I can't ping my board from my computer... It doesn't send any reply...

I hope this will help you searching what's wrong !!
Good luck !

Bye


Message Edited by cimcim on 2008-03-14 10:15 AM
0 Kudos

435 Views
aurelihein
Contributor I
Hi,
I don't think that you need a cross cable . . . you should be able to ping the card under the redboot . . .
Regards,
aurelien
0 Kudos