MQX Debugger Issue

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX Debugger Issue

Jump to solution
552 Views
davidzhou
Contributor V

Hi,

I have Code Warrior 10.6.4.FSL_b06015 license, and MQX4.2 installed with K60 tower.

Earlier, I had posted the same question, and I thought the issue is resolved. But it keeps coming back.

I have deleted created a new MQX4.2 project and copied source code into the newly created project, and recompiled bsp, psp, and application. The debugger starts and failed at

  kernel_data = (KERNEL_DATA_STRUCT_PTR) _ALIGN_ADDR_TO_HIGHER_MEM(mqx_init->START_OF_KERNEL_MEMORY);

    /* Set the global pointer to the kernel data structure */
    _SET_KERNEL_DATA(kernel_data);   //DEBUGER FAILED AT THIS LINE: with error messages:

   target request failed, not allowed to access registers

I examined the mqx_init structure and saved and attached the screen dump.

I have created the second smaller MQX4.2 project, without problem of debugging. I also posted the mxq_init structure screen dump.

It seems there is a memory problem. The project was created 1 year ago (was be able to debug, and recently had problem, and the problem went away after recompiling bsp).

Could please examine the mxq_init? Is there a memory out of bound problem? But there is no warning or error of compilation, though.

Thank you,

David Zhou

0 Kudos
1 Solution
390 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi David:

There is a macro in your link file, __KERNEL_DATA_VERIFY_ENABLE, could you please first try to enable this macro to verify the kernel_data?

intflash.ld

    __KERNEL_DATA_VERIFY_ENABLE = 0;    /* Test SDRAM read/write */

please note that this process will take about several minutes .

Regards

Daniel

View solution in original post

0 Kudos
3 Replies
391 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi David:

There is a macro in your link file, __KERNEL_DATA_VERIFY_ENABLE, could you please first try to enable this macro to verify the kernel_data?

intflash.ld

    __KERNEL_DATA_VERIFY_ENABLE = 0;    /* Test SDRAM read/write */

please note that this process will take about several minutes .

Regards

Daniel

0 Kudos
390 Views
davidzhou
Contributor V

Hi Daniel,

 I was away for long period of time, and didn't have chance to give it back to you. Sorry for that.

I have recreated whole project file and imported source code into the new project. Everything is fine so far. Thank you very much.

David Zhou

0 Kudos
390 Views
davidzhou
Contributor V

Added screen dumps. ProjFailedDebug.png

SamllerProjOk_Debug.png

0 Kudos