Kwikstik „demo“ MQX 4.0 project problem

cancel
Showing results for 
Search instead for 
Did you mean: 

Kwikstik „demo“ MQX 4.0 project problem

361 Views
fowler69
Contributor I

Hello,

I have Kwikstik dev. kit. I want to open „demo“ MQX 4.0 project in CodeWarrior 10.4 (new MQX 4.0 project -> … -> Example application -> demo example..), but when I build it, there is several error:

„mingw32-make:***[Sources/atimesli_c.obj] Error 1

mingw32-make:***[Sources/btimesli_c.obj] Error 1

mingw32-make:***[Sources/demo _c.obj] Error 1

mingw32-make:***[Sources/evanta _c.obj] Error 1

mingw32-make:***[Sources/evantb _c.obj] Error 1

mingw32-make:***[Sources/main _c.obj] Error 1

and

„preprocessor #error directive“ in

#error SEMAPHORE component is currently disabled in MQX kernel. Please set MQX_USE_SEMAPHORES to 1 in user_config.h and recompile kernel.

When I tryed older versions of MQX or CW, the problems were same.

Is there any chance to run this project?

Thank you!

0 Kudos
1 Reply

95 Views
Martin_
NXP Employee
NXP Employee

The "demo" makes use of semaphores. As the error message instructs you, you should enable MQX_USE_SEMAPHORES (define it to 1 in user_config.h), build MQX libraries with this user configuration, then the "demo".

You can try "lwdemo" which should give you similar functionality by using lightweight components, thus, you will be able to build this, without any modification to the default user_config.h. After MQX installation, you need to build MQX libraries anyway.