MPC5744P dev board - uart example does not work, why?

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5744P dev board - uart example does not work, why?

87 Views
Contributor I

I have the above mentioned board and tried the builtin uart demo which use LINFlexD and I using Termite as terminal setting the baud rate to 19200 just as it was set in the source code, but when I run it with debuger in S32DS then nothing will be printed to the terminal. Tested the terminal software, it is working with an arduino UNO so the problem should be elsewhere.

What I found out that my board is a revision E which somewhat differ from B. There is a documentation which even mention the following " USB/serial/OpenSDA is connected to LIN0 (LIN1 on Rev.B) ". It could be that the original program was written to the B version? I can't verify this since I'm quite a beginner with this board and not sure what exactly going on in the source.

The example name is "LINFlexD_UART_MPC5744P" by the way

UPDATE: So my assumption is that if with rev E the serial is connected to LIN0 (LINFlexD_0), then I should call thats initialization function, because its exists there, it just unused. But as soon as the control enter to that function it will run into an interrupt IVOR1_Vector where it stays for ever (like a trap mechanism in TriCore I assume), but I am unsure what the meaning of this "trap".

Labels (1)
Tags (2)
0 Kudos
1 Reply

5 Views
NXP TechSupport
NXP TechSupport

Hi,

most probably the exception will be called due to clock gated on LINFlex_0. Add below line to peri_clock_gating()

MC_ME.PCTL204.B.RUN_CFG = 0x1; //LINFlexD_0: Select peripheral config RUN_PC[1]

Then use LINFlex0 functions

initLINFlexD_0(80,19200);

testLINFlexD_0(); /* Send test message to PC terminal.*/

for(;;)
{
    echoLINFlexD_0();
}

BR, Petr

0 Kudos