Failing to debug using Flash on the MPC5777C-DEVB

cancel
Showing results for 
Search instead for 
Did you mean: 

Failing to debug using Flash on the MPC5777C-DEVB

196 Views
adam_lewis
Contributor I

Hi,

I cannot get any program to run on my MPC5777C from flash. I am using a PE Micro Multilink Universal FX and S32 Design Studio v2.1.

S32 gives an option to create example projects, and I am using the MPC5777C hello world project, which just flashes an LED.

The project has two debug configurations by default; debug flash and debug RAM.

When I launch with debug RAM, I can get into main() and step, however the LED does not flash.

I cannot launch with debug flash, it looks like it never successfully programs the board. This is the point at which it gets stuck:

Loading programming algorithm ...
Done.
Programming sequency is : erase, blank check, program, and verify {default}
CMD>VC
Verifying object file CRC-16 to device ranges ...
block 00800000-00800007 ...

For the project that I am working on, I will need to run from Flash. How can I accomplish this?

Many thanks,

Adam

0 Kudos
2 Replies

100 Views
petervlna
NXP Employee
NXP Employee

Hi,

this should be very simple.

Could you explain me the steps you are doing when you open demo project and compile and load it ho board?

If you can attach screens that will help.

regards,

Peter

PS: how about other SDK examples? Do the work for you?

0 Kudos

100 Views
adam_lewis
Contributor I

Hi Peter,

I have managed to resolve my issue. The fix for me was reducing the "Debug Shift Frequency" in the debug config from its default of 5000KHz to 2500KHz.

Thanks,

Adam

0 Kudos