Debug console LPUART MKW41Z

cancel
Showing results for 
Search instead for 
Did you mean: 

Debug console LPUART MKW41Z

334 Views
florian_lebrun5
Contributor III

Hi I would like to use for debug pupose LPUART ( pin PTC6 and PTC7). I 'm using the rigado kit.

I m able to run hello worl example.

But when i try to do the same step in my project, it doesn t work. Now i even have a compilation error on the printf function. I tried to comapre each piece of code and clock , it seems the same. The only difference is the example force the systeme clock value to 40 000 000hz, mine use the 20,869Mhz from clock syteme.

I try to import in the herat rate monitor sdk exemple in appMain.c during init phase sequence. I join the picture of code . 

Thanks  lot i m a bit stuck :smileysad: .Untitled.png

0 Kudos
2 Replies

170 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Florian Lebrun,

    I find you already make this post as assumed answered.

    Do you have solved the problem or not?

   If you can enter the debug mode, the problem should in the clock configuration area, you can check your board the clock configuration, you must make sure your system clock is correct, then configure the uart with the according UART source clock.

   If you still have problem about it, please kindly let me know.

  


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

170 Views
florian_lebrun5
Contributor III

Hi ,

It is OK, by setting SDK_DEBUGCONSOLE =1 it works, strange cause i had the same option than in hello_world project ( =0) but it doesn t worked. in case of hello_world it seems to work with =0.

0 Kudos