Peripheral Tool Syntax Error

cancel
Showing results for 
Search instead for 
Did you mean: 

Peripheral Tool Syntax Error

502 Views
Contributor IV

Hi ı am using MCUXpresso 11.1.1 and SDK_2.7.0_MIMXRT1052xxxxB. When ı tried to use Peripherals tool ı get syntax error. I tried to use another pc with  Windows 10 and get same result . Is that a common problem or something missing. 

p.s. Tool works with linux.

Tags (2)
0 Kudos
10 Replies

255 Views
NXP Employee
NXP Employee

Hello,

It could be problem in the Peripherals tool component, however, so far I'm not able to reproduce it on my side. Would be possible to attach MCUXpresso IDE project that demonstrates the issue?

Many thanks!

Lukas

0 Kudos

255 Views
Contributor IV

Hi Lukas,

Thanks for your reply.

I cant attach into the comment so ı attached  project to main question.

Kind Regards.

0 Kudos

255 Views
NXP Employee
NXP Employee

Hi Omer, 

we tried to open your project on multiple Windows 10 machines but were not able to reproduce it, each time we opened your project the missing parts were added.

Can you please try to:

1. Uninstall the MCUXpresso IDE 11.1.1

2. Remove c:\ProgramData\NXP\mcu_data_v8\ directory

3. Install the MCUXpresso IDE 11.1.1

Eventually, you can also consider moving to the new MCUXpresso 11.2: https://community.nxp.com/community/mcuxpresso/mcuxpresso-ide/blog/2020/07/21/mcuxpresso-ide-v1120-n... 

Regards,

Lukas

0 Kudos

255 Views
Contributor IV

Hi Lukas,

We tried your suggestions.

1. Uninstall the MCUXpresso IDE 11.1.1

2. Remove c:\ProgramData\NXP\mcu_data_v8\ directory

3. Install the MCUXpresso IDE 11.2.0

and update sdk but result not changed. Not sure what you mean by " each time we opened your project the missing parts were added." When we tried to open project with another windows10 or linux machine, there is no warning or no error. 

0 Kudos

255 Views
Contributor IV

Hi Lukas,

Sorry the bother. Irrelevant update from the subject. MCUXpresso IDE 11.2.0 crashed somehow. Can not open sdk(2.8.0) which ı updated with IDE. I have been using IDE for about 8 hours and close the ide. When ı open it again error occurs, failed to open readme.txt file in workspace ( workspace \.mcuxpressoide_packages_support\readme.txt).    The SDK which i installed did not appear. I delete and install it over and over again  but it did not worked and did not let me reinstall sdk. I am back to previous version 11.1.1.

0 Kudos

255 Views
NXP Employee
NXP Employee

Hi Omer,

I meant that after opening your project using Peripherals tool in MCUXpresso IDE 11.1.1 the missing code in peripherals.c is added.

Can you please attach following files?

c:\Users\<your_user_name>\Documents\MCUXpressoIDE_11.1.1_3241\workspace\.metadata\.log
c:\Users\<your_user_name>\Documents\MCUXpressoIDE_11.2.0_4120\workspace\.metadata\.log

Thanks!

Lukas 

0 Kudos

255 Views
Contributor IV

Hi Lukas,

I attached .log file (v11.1.1)  to main question. I deleted 11.2.0. 

0 Kudos

255 Views
NXP Employee
NXP Employee

Hi Omer,

I have consulted your problem with another MCUXpresso Config Tools developer and he suggested to ask you to attach also content of c:\ProgramData\NXP\mcu_data_v7\components directory for further analysis. 

Also I noticed I have typo in one of my previous instructions, I suggested to remove the c:\ProgramData\NXP\mcu_data_v8\ directory, where I actually wanted to ask to remove c:\ProgramData\NXP\mcu_data_v7\ directory...

 Sorry for the inconveniences, I hope with the components directory we will be able to finally crack the problem...

Regards,

Lukas 

0 Kudos

255 Views
Contributor IV

Hi Lukas,

I attached c:\ProgramData\NXP\mcu_data_v7\components to main question. Thanks for your time.

0 Kudos

255 Views
Contributor IV

Hi Lukas ,

Any update for this problem ? I set a new Ubuntu 20.04 machine,  Config Tool generate code with no error. 

0 Kudos