IDE v11.2.1, after terminate debug session I must physically remove/connect usb to debug again

cancel
Showing results for 
Search instead for 
Did you mean: 

IDE v11.2.1, after terminate debug session I must physically remove/connect usb to debug again

114 Views
Contributor I

I'm using a Windows 10 machine and a fresh install of MCUXpresso IDE v11.2.1 and I'm trying to connect to a LPCXpresso LPC1115 Rev.A with LPC-Link (from here: https://www.embeddedartists.com/products/lpc1115-lpcxpresso/).
After connecting the board via USB, I can debug the board normally. After pressing terminate (stop button), I cannot reconnect to the board via USB by pressing the debug button. After physically disconnecting the USB and reconnecting the USB cable, I can then press debug and it will debug normally.

When using the same board I have the same problem on LPCXpresso IDE v8.2 but this problem doesn't occur on LPCXpresso IDE v7.9. However, I'm only concerned with fixing this issue on MCUXpresso IDE.

Below are the error messages which popup when this error occurs.

error1.pngerror2.pngerror3.pngerror4.pngerror5.png

Let me know if you need more info to diagnose/fix this issue, or if there's a simple way to fix this issue.

Thanks.

0 Kudos
3 Replies

63 Views
Contributor I

Hello Alice,

I tried using the "clean up debug" to end a debugging session and the same error occurs.

Regards,

Chris

0 Kudos

49 Views
NXP TechSupport
NXP TechSupport

Hello Chris,

As the LPCXpresso LPC1115 is old product,t he MCUXpresso IDE is new, so maybe there is some compatibility problem.

And what about a simple project?

 

Regards,

Alice

0 Kudos

89 Views
NXP TechSupport
NXP TechSupport

Hello chris_i_roberts,

 

How about clean debug by click" Clean Up Debug" button before next connect.

Alice_Yang_0-1602642485086.png

 

 

Regards,

Alice

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 
 
 
 
 
 

 

 

 

 
0 Kudos