Build Server - Mcuxpressoidec: Java was started but returned exit code=1

cancel
Showing results for 
Search instead for 
Did you mean: 

Build Server - Mcuxpressoidec: Java was started but returned exit code=1

63 Views
Contributor I

I am setting up a build server for an MCUXpresso Project, and I have configured it to build the Release configuration. The build finishes correctly but the build server is reporting that it failed with the following message:

 

Mcuxpressoidec:
Java was started but returned exit code=1
-Djava.class.path=C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\\plugins/org.eclipse.equinox.launcher_1.5.600.v20191014-2022.jar
-os win32
-ws win32
-arch x86_64
-launcher C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\mcuxpressoidec.exe
-name Mcuxpressoidec
--launcher.library C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1100.v20190907-0426\eclipse_1902.dll
-startup C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\\plugins/org.eclipse.equinox.launcher_1.5.600.v20191014-2022.jar
--launcher.overrideVmargs
-application org.eclipse.cdt.managedbuilder.core.headlessbuild
-import ./ADTi-200
-cleanBuild ADTi-200/Release
-vm C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\jre\bin\server\jvm.dll
-vmargs
-Djava.class.path=C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\\plugins/org.eclipse.equinox.launcher_1.5.600.v20191014-2022.jar 
##[error]Process completed with exit code 1.

 

I am using a batch file to run the build with the following contents:

 

rem Batch file that builds firmware for release

@echo off

rem path to build tools
SET TOOLCHAIN_PATH=C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\tools\bin

rem path to command line executable for MCUXpresso
SET IDE=C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\mcuxpressoidec.exe

ECHO Extending PATH if not already present
ECHO %PATH%|findstr /i /c:"%TOOLCHAIN_PATH:"=%">nul || set PATH=%PATH%;%TOOLCHAIN_PATH%

ECHO Launching MCUXpresso IDE
"%IDE%" -nosplash --launcher.suppressErrors -application org.eclipse.cdt.managedbuilder.core.headlessbuild -import "./ProjectName" -cleanBuild ProjectName/Release

 

Manually running the batch file reports build succeeded with no errors, but the server reports it failed due to the Java error in mcuxpressoidec.exe.

How can I fix this issue?

0 Kudos
2 Replies

56 Views
Senior Contributor III

I would guess that there *is* an error being reported in the build - check the complete build log.

0 Kudos

41 Views
Contributor I

I've checked through the whole log, the only error is the one in my post which appears at the end after the build finishes

0 Kudos