Using Segger J-link plus with FRDM-KV31F. Target machine actively refused it.

cancel
Showing results for 
Search instead for 
Did you mean: 

Using Segger J-link plus with FRDM-KV31F. Target machine actively refused it.

723 Views
timboatman
Contributor I

When I try to use the Segger J-Link plus with an FRDM-KV31F I get the following message.

"localhost:2336: No connection could be made because the target machine actively refused it."

In the console I get this, "Checking target voltage...  Connecting to target failed. Connected correctly?

GDB Server will be closed..."

I attach a photo of my connection - Have I done it right?

If I have, any clues as to what is going on?

I also am attaching the messages generated.  The first window message is also duplicated in the console.

I've also attached the Configuration for the Segger probe in MCUXpresso.  If I change from SWD connection to JTAG the results are the same.

Thanks for your help.

Tim Boatman

0 Kudos
1 Reply

434 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Tim Boatman ,

Could you please usa a demo project to have a try ? I just test on my side , it can work well.

And use the Debug button in "Quickstart Panel"

pastedImage_1.png

About debug , you can also have a look at "Chapter 11. Debugging a Project -> Debugging Overview"

of "MCUXpresso IDE User Guide".

Hope it helps,


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos