Linking MultiCore Binaries on LPC43S37

cancel
Showing results for 
Search instead for 
Did you mean: 

Linking MultiCore Binaries on LPC43S37

235 Views
richardcopeman
Contributor II

HI,

First off, apologies if this has been asked elsewhere and if it has can someone kindly point me at a link.

I'm using LPCXpresso 11.0.0_2516 and have created just two projects: one for each core on my LPC 43S37 Xpresso board (OM13073).

First I created  project called sieve_m0 and selected LPC43S37-M0 as the processor type and LPC_18x7_43x7_2x512_BootB.cfx as the linker script. I created this as type M0APP.

Then I created a second project called sieve_m4, set the board to LPCXpresso 43S37, set the linker to LPC_18x7_43x7_2x512_BootA.cfx and the processor type to LPC43S37 (to target the M4). In the wizard, I set M0APP to point to sieve_m0 and set M0APP to load from FLASH not RAM.

 

I can build the sieve_m0 with no problems. I have not added any code yet; I just want to check that it all builds without me messing around.

If I try to build the M4 project I get an error (again as it has been generated - no code of my own added yet):

ld.exe: M0APP execute address differs from address provided in source image.

I've attached two images showing my settings page for each project.

Can someone tell me what I've done wrong, please?

TIA,

Richard

0 Kudos
1 Reply

190 Views
converse
Senior Contributor V

Did you follow the procedure outlined in the (pretty comprehensive) MCUXpresso User Guide - chapter 19.

0 Kudos