ConfigTools only work on right click from project

cancel
Showing results for 
Search instead for 
Did you mean: 

ConfigTools only work on right click from project

171 Views
Senior Contributor I

This isn't really a bug report, just some UX feedback. If you create a new project and select ConfigTools | Clocks (for example) from the menu bar, it complains that no MCU is selected and gives you no option to select an MCU, or indeed any information about what's going on at all.

The correct answer (covered in the instruction manual, which is why this isn't a bug report) is to right-click on the project in the project explorer and open ConfigTools from there the first time.

This seems pointlessly confusing.  There are at least two other ways to get to the configuration perspectives, both of which are visible without clicking on anything and would seem to be the more obvious ways to get there.  They should either launch the first-time setup like the right-click menu does, or they should at least be hidden or disabled until the configuration is created.

Labels (1)
0 Kudos
2 Replies

NXP Employee
NXP Employee

Hello Scott,

thank you for the feedback, we are aware about this and we plan to improve the functionality. The main menu is just for easier switching the perspectives, it is not meant as an explicit action to create Config Tools configuration, which requires downloading data, creating MEX file and other things.This explicit action can be done using popup menu or bar menu in "Project Explorer" view, or also from "Quickstart Panel" view.

On the other side I have to admit that it might be confusing for new users. Anyway we internally track the requirement to improve this.

Regards,

Libor

0 Kudos

NXP Employee
NXP Employee

Hi Scott,

thanks for your feedback. It is also possible to select eclipse project from the drop down list on the toolbar:

Capture.PNG

Hope this helps.

Regards

Marek

Regards,
Marek
0 Kudos