ls1021atwr boot issue

cancel
Showing results for 
Search instead for 
Did you mean: 

ls1021atwr boot issue

600 Views
matt8156
Contributor I

Hi

 

I am trying to load a new OS image onto the LS1021ATWR development board and having a few problems.

 

I have downloaded and installed the QorIQ SDK V2.0-1703 including the "image" iso. I have built the core and minimal OS images and attempted to boot from the SDcard by loading the images to a ramdisk and booting from this. However i get a few errors once the filesystem is mounted which include:

Bad inittab entry at line 5

 

and

 

can't open /dev/si: No such file or directory
can't open /dev/~~: No such file or directory
can't open /dev/l0: No such file or directory
can't open /dev/l1: No such file or directory
can't open /dev/l2: No such file or directory
can't open /dev/l3: No such file or directory
can't open /dev/l4: No such file or directory

 

I have tried the same test using the pre-built images from the SDK Images iso and get the same errors.

 

I have also compared the inittab file to that pre-installed in the NOR flash on the development card and line 5 appears to be identical.

 

My uboot environment for testing against the pre-built images is

baudrate=115200
bootargs=‘root=/dev/ram0 rw rootdelay=5 ramdisk_size=40000000 console=ttyS0,115200’
bootcmd=mmcinfo;ext2load mmc 0:2 $loadaddr /boot/$bootfile;ext2load mmc 0:2 $fdtaddr /boot/$fdtfile;ext2load mmc 0:2 $fsaddr /$filesystemfile;bootm $loadaddr $fsaddr $fdtaddr
bootdelay=3
bootfile=uImage-ls1021atwr_image.bin
dnsip=10.192.130.201
eth1addr=00:04:9f:04:e1:f9
eth2addr=00:04:9f:04:e1:fa
ethact=eTSEC3
ethaddr=00:04:9f:04:e1:f8
ethprime=eTSEC3
fdt_high=0xffffffff
fdtaddr=8f000000
fdtcontroladdr=bef0ed34
fdtfile=uImage-ls1021a-twr_image.dtb
filesystemfile=fsl-image-core-ls1021atwr-20160514210716.rootfs.ext2.gz.u-boot
fsaddr=88000000
gatewayip=10.193.20.254
initrd_high=0xffffffff
ipaddr=10.193.20.191
loadaddr=83000000
netmask=255.255.255.0
scsidevs=0
serverip=10.192.208.233
stderr=serial
stdin=serial
stdout=serial

and i have attached a log of the boot sequence.

 

Any ideas?

 

Thanks

Matt

Original Attachment has been moved to: boot.txt.zip

Labels (1)
0 Kudos
5 Replies

345 Views
Pavel
NXP TechSupport
NXP TechSupport

Find u-boot image files in the following folder:

QorIQ-SDK-V2.0-20160527-yocto/build_ls1021atwr/tmp/deploy/images/ls1021atwr

 

Find the following file:

u-boot-sdcard-ifc-2016.09+fslgit-r0.bin

 

See the Section 4.4.4.7 of nXP SDK 2.0-1703 documentation:

http://www.nxp.com/docs/en/supporting-information/QORIQ-SDK-2.0-IC-REV0.pdf


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

345 Views
matt8156
Contributor I

Hi,

 

Thanks for your replies, I fixed my issue by reinstalling the QorIQ SDK and rebuilding the OS. Updating Uboot was not necessary.

This worked for both the LS1046ARDB and LS1021ATWR.

 

Thanks

Matt

0 Kudos

345 Views
matt8156
Contributor I

OK, There do not seem to be any pre-built images for the ls1021atwr in the V2.0-1703 download.

I have built the images myself but which one should i use? the instructions you refer to do not define the file.

I would guess it is u-boot-nor.bin?

0 Kudos

345 Views
Pavel
NXP TechSupport
NXP TechSupport

Test your board using u-boot on SD card from the QorIQ SDK V2.0-1703.

Find the "Programming U-boot to SD card" in the Section 4.4.4.7 of NXP SDK 2.0-1703 documentation:

http://www.nxp.com/docs/en/supporting-information/QORIQ-SDK-2.0-IC-REV0.pdf


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

345 Views
matt8156
Contributor I

Hi,

It appears i'm having the same issue with the LS1046ARDB.

i get the same errors after the kernel starts up:

Bad inittab entry at line 5

 

and

 

can't open /dev/si: No such file or directory
can't open /dev/~~: No such file or directory
can't open /dev/l0: No such file or directory
can't open /dev/l1: No such file or directory
can't open /dev/l2: No such file or directory
can't open /dev/l3: No such file or directory
can't open /dev/l4: No such file or directory

I can't get your pre-built images to work because you don't provide the rootfs which i need to load from the SDCard on this target

Any further suggestions?

Thanks
Matt

0 Kudos