SDK 2.4 for LS1043ARDB

cancel
Showing results for 
Search instead for 
Did you mean: 

SDK 2.4 for LS1043ARDB

815 Views
marje
Contributor I

Hi,

I'm building platform project for reference board LS1043ARDB, based on Linux SDK 2.4.3 and I have successfuly created target images for fsl-image-networking. But, I have a problem with booting the target from SD card or NOR (Bank4) which was configured with steps from my attachment uboot-setup.txt.

Booting from SD card or NOR fails after probing OPTEE driver with the same error (attachments: boot-from-sd-card.txt, boot-from-NOR-bank4.txt).

If I disable TEE driver in kernel, I have another problems with loading/probing fsl_XXX networking drivers (boot-from-sd-card-without-TEE.txt).

I'd also like to know, how to solve the issues shown from u-boot (it complains about different firmware images).

Thanks in advance,

Labels (1)
Tags (2)
0 Kudos
5 Replies

162 Views
marje
Contributor I

Hi,

I've also tested this filesystem on SD card with prebuild u-boot image from LSDK 18.03 (http://www.nxp.com/lgfiles/sdk/lsdk1803/firmware_ls1043ardb_uboot_sdboot.img ).

Using this image solves my problems about booting and using network interfaces.

And now the question: How can I generate the same image from yocto?

Thanks,

0 Kudos

162 Views
marje
Contributor I

Hi,

if you check again the last one of my posts, I used exactly the same image and had problems I described in my initial report. Does this board work with version 2.4?

Maybe you have missed my last question so, I'm asking again: is there any documentation available for SDK 2.4?

Thanks,

0 Kudos

162 Views
Pavel
NXP TechSupport
NXP TechSupport

Use the u-boot-sdcard-2017.09+fslgit-r0.bin instead of u-boot-with-spl-pbl.bin.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

162 Views
marje
Contributor I

Hi Pavel,

I've already followed to this document for SDK 2.0. The document is referencing to image u-boot-with-spl-pbl.bin, but SDK 2.4 builds only following SD card images:

u-boot-sdcard-2017.09+fslgit-r0.bin
u-boot-sdcard-dtb-secure-boot-2017.09+fslgit-r0.bin
u-boot-sdcard-secure-boot-2017.09+fslgit-r0.bin
u-boot-sdcard-spl-secure-boot-2017.09+fslgit-r0.bin

Because I do not need secure mode I've deployed image u-boot-sdcard-2017.09+fslgit with command:

# sudo dd if=u-boot-sdcard-2017.09+fslgit-r0.bin of=/dev/sdd seek=8 bs=512

which reports problems about wrong firmware images and no ethernet (u-boot logs were attached in my first question).

Is there any document available for SDK 2.4? Currently, I have no information what are the involved u-boot variables and what are the correct values. Comparing to older SDK 2.0, the u-boot environment has changed a lot in SDK 2.4.

Thanks

0 Kudos

162 Views
Pavel
NXP TechSupport
NXP TechSupport

Look at the Section 4.4.7.8 of NXP SDK 2.0-1703 documentation:

https://www.nxp.com/docs/en/supporting-information/QORIQ-SDK-2.0-IC-REV0.pdf

This Section contains command sequence for programming a new U-Boot, RCW, FMan Microcode, PPA firmware to the NOR Flash

 

 

Look at the Section 4.4.7.9.4 of NXP SDK 2.0-1703 documentation.

 

This Section contains command sequence for SD deployment Linux and u-boot images.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos