LS1043A RDB How to change CPU frequency

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LS1043A RDB How to change CPU frequency

475 Views
daweichen
Contributor III

Hi NXP,

I have an LS1043A RDB.  Its SD slot has a bootable SD card that contained a default BSP image. On start-up, u-boot reports the SoC's quad cores are at 1.6 GHz.

After the boot process has completed, I used the following command to check the CPU frequency.  

root@ls1043ardb:/sys/devices/system/cpu/cpu0/cpufreq# cat cpuinfo_cur_freq
500000

root@ls1043ardb:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_cur_freq
500000

I then used the following command to check available CPU frequencies.

root@ls1043ardb:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_available_frequencies
1600000 1000000 800000 500000

I wanted to set the frequency to maximum. I tried the following command and found it futile. 

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

I tried the procedure described in 

CPU Frequency Switching User Manual | QorIQ SDK v2.0-1703 Documentation | NXP Semiconductors

and found the frequency remained unchanged (@ 500000).  Setting "scaling_speed" appears to be useless.

I was wondering what had to be done to set the CPU frequency to 1.6 GHz.  

Thank you so much,

Dawei

 

[Reference 1]

U-Boot 2021.04-ge2eba0cd58 (Aug 27 2021 - 22:19:59 +0800)

SoC: LS1043AE Rev1.1 (0x87920011)
Clock Configuration:
CPU0(A53):1600 MHz CPU1(A53):1600 MHz CPU2(A53):1600 MHz
CPU3(A53):1600 MHz
Bus: 400 MHz DDR: 1600 MT/s FMAN: 500 MHz
Reset Configuration Word (RCW):
00000000: 08100010 0a000000 00000000 00000000
00000010: 14550002 80004012 60040000 c1002000
00000020: 00000000 00000000 00000000 00038800
00000030: 00000000 00001100 00000096 00000001

0 Kudos
3 Replies

405 Views
Hmc510
Contributor II

I think you can modify the RCW cpu clock

0 Kudos

440 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please check whether these Kernel configurations CONFIG_CPU_FREQ, CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE and CONFIG_QORIQ_CPUFREQ be enabled in your Linux Kernel with the following command.

# zcat /proc/config.gz | grep CONFIG_CPU_FREQ

0 Kudos

215 Views
daweichen
Contributor III

I found my problem.  Linux 5.4 kernel has CONFIG_QORIQ_THERMAL=y as the default  Changing CONFIG_QORIQ_THERMAL=n fixed my CPU frequency problem.

 

Thank you very much for your help.

0 Kudos