How to force LS1012A PCIe into Gen 1 mode?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to force LS1012A PCIe into Gen 1 mode?

257 Views
jasonwu0527
Contributor I

I installed the PI7C9X2G304SLBFDE PCI-E switch kit on LS1012ARDB, but sometimes it can't be detected PCI-E switch.

P_20180731_142149.jpg

I would like to force it into Gen 1 mode for testing, how to modify the drivers and force Gen 1 mode?

Thank you.

Can detect:
root@TinyDistro:~# cat /proc/bus/pci/devices
0000 19578100 1e 0 0 0 0 0 0 4040000000 0 0 0 0 0 0 800 pcieport
0100 12d82404 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport
0208 12d82404 1f 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport
0210 12d82404 20 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport
0218 12d82404 21 0 0 0 0 0 0 0 0 0 0 0 0 0 0 pcieport


Not detect:
root@TinyDistro:~# cat /proc/bus/pci/devices
0000 19578100 1e 0 0 0 0 0 0 4040000000 0 0 0 0 0 0 800 pcieport

Labels (1)
Tags (3)
0 Kudos
1 Reply

75 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Jason Wu,

You could change Link_Control_2_Register[T_LS] register value to force link speed down to Gen1.

The offset of this register is 0xA0, PEX1 address is 0x3400000.

Under u-boot

=> md 0x34000a0 1
034000a0: 00010002                               ....
=> mw 0x34000a0 0x00010001

=> md 0x34000a0 1

034000a0: 00010001


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos