character not Received on UART

cancel
Showing results for 
Search instead for 
Did you mean: 

character not Received on UART

131 Views
Contributor I

Hello, 

I am initialising the driver as follows. example code is for UART2. the same effect is seen also for UART1. 

void InitUART2(void)
{
Driver_USART2.Initialize(USART2_SignalEvent_t);
Driver_USART2.PowerControl(ARM_POWER_FULL);
Driver_USART2.Control(ARM_USART_MODE_ASYNCHRONOUS, 115200);

// Enable RX und TX
Driver_USART2.Control(ARM_USART_CONTROL_TX, 1);
Driver_USART2.Control(ARM_USART_CONTROL_RX, 1);
}

I am able to sent the characters to the tera term. I am not able to get the character receive event 

void USART2_SignalEvent_t(uint32_t event)
{
if (ARM_USART_EVENT_SEND_COMPLETE == event)
{
__asm("nop");
}
if (ARM_USART_EVENT_RECEIVE_COMPLETE == event)
{
__asm("nop");
}
if (ARM_USART_EVENT_RX_OVERFLOW == event)
{
__asm("nop");
}
}

//Any more setting to be done more to get the characters reception?

Regards,

Suhas Prabhu

Tags (3)
0 Kudos
5 Replies

25 Views
Contributor I

hi Kerry,

The issue got solved. It was issue with the edited driver in the third party software. Comparison of the driver lead to the solution.

Thanks again for the help.

Regards,

Suhas

0 Kudos

25 Views
NXP TechSupport
NXP TechSupport

Hi Suhas,

  It's good to hear you solved it.

  If you have the new question in the future, welcome to create the new case!

  Now, please help to mark the correct answer, just to close this case, thank you!


Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

25 Views
Contributor I

Hi Kerry,

Thanks for the reply.

I am using MK22FN512VLL12, I will check the MUX part in the port register.

Regards,

Suhas Prabhu

0 Kudos

25 Views
NXP TechSupport
NXP TechSupport

Hi Suhas Prabhu,

   You are welcome.

  After you check it, if you still have question about it, just let me know.


Have a great day,
Kerry

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

25 Views
NXP TechSupport
NXP TechSupport

Hi Suhas Prabhu ,

   Do you configure the UART2 TX and RX pin function, select the correct MUX in the PORT register?

   BTW, what the detail kinetis chip you are using? Please tell me the chip part number.


Have a great day,
Kerry

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos