canbus problem

cancel
Showing results for 
Search instead for 
Did you mean: 

canbus problem

55 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by cseb on Tue Nov 27 12:22:32 MST 2012
Hi everyone,

I have two canbus development boards. One of them must send canbus data to another. But they can not communicate with eachother. Before everything, I have to be sure that my hardware design is correct. For the application I have used TJA1042T IC . The schematic represantation is below. Can you help me please?

Labels (1)
0 Kudos
6 Replies

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by fpga_avr on Tue Aug 13 21:17:36 MST 2013
plz past your complete source here to all see and help
0 Kudos

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by cseb on Fri Jan 11 10:53:11 MST 2013
I can now send data but i can not receive data. At the receiver part on the GLCD the incoming data is always zero. For receiving I am using the following routine:

  if (CAN_RxRdy[1]) {                           /* rc message on CAN Controller #2 */
  CAN_RxRdy[1] = 0;
  val_Rx = CAN_RxMsg[1].data[0];
  sprintf(f1,"%d",val_Rx);
  ks0108_text(30,30,f1,1,1);
  }

By the way I am using CAN2 controller ( P0.4 & P0.5 ), so I am using the following definitions for CAN2 block in can.c can_setup() function:

    LPC_SC->PCONP       |=  (1 << 14);           /* Enable power to CAN2 block */
    LPC_PINCON->PINSEL0 |=  (1 << 9);           /* Pin P0.4 used as RD2 (CAN2) */
    LPC_PINCON->PINSEL0 |=  (1 << 11);           /* Pin P0.5 used as TD2 (CAN2) */

Please help me. :(
0 Kudos

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by cseb on Tue Nov 27 23:52:22 MST 2012
I have tried c:/keil/arm/boards/keil/mcb1700/can software. I am not sure it works or not? Maybe there is someone tried this software.
0 Kudos

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by Ex-Zero on Tue Nov 27 15:37:32 MST 2012
#1 Did you test your CAN software with self test mode?

#2 It's easier to use real 3.3V CAN transceiver like SN65HVD231 from TI.
0 Kudos

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by cseb on Tue Nov 27 14:04:11 MST 2012
I changed the connection of STB pin to GND but i still can not solve my problem.
0 Kudos

2 Views
NXP Employee
NXP Employee
Content originally posted in LPCWare by martinho on Tue Nov 27 13:59:25 MST 2012
Hi,

You connected STB (Pin8) to VCC, this put's the TJA1042T in standby! STB needs to be low to make the TJA1042T working. Further be sure to have a TJA1042T/3 or a TJA1042TK/3, only this type has the VIO Pin.

Martin
0 Kudos