SPI HS LPC55S16-EVK

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SPI HS LPC55S16-EVK

673 Views
embedded_eng_
Contributor III

Hi,

I'm trying to use lpcxpresso55s16_spi_HS_LSPI_dma_b2b_transfer_master example with LPC55S16-EVK.

The only changes I did to the example code are:

1. SPI_SSEL variable, which I changed from 1 to 0 (change in pin_mux as well).

2.  EXAMPLE_MasterInit, EXAMPLE_MasterDMASetup, EXAMPLE_MasterStartDMATransfer, EXAMPLE_TransferDataCheck and SPI_Deinit inside a infinite loop, so it will transfer non stop.

 

I'm trying to communicate with a IC flash (W25Q32JVDAIQ).

I can see MOSI, CLK and SSEL lines move with a oscilloscope, but MISO doesn't move.

All RX I get is 0xff, 0xff...

Looking into the SDK example, I saw that the TX data is determined by:

    for (i = 0U; i < TRANSFER_SIZE; i++)
    {
        /* SPI is configured for 8 bits transfer - set only lower 8 bits of buffers */
        spiMasterTxData[i] = i % 256U;
    }

So first byte is 0x00, second one is 0x01 etc..

SPI first byte should be the instruction code, so I'm not sure what is expected to happen sending this tx buffer.

 

I've tried to change the TX buffer so it will issue a read command, but got 0xff 0xff.. as well.

Maybe someone can help?

 

Thanks.

Tags (4)
0 Kudos
1 Reply

661 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello embedded_eng_,

If the MISO signal is  0xFF from oscilloscope, I think you should first check slave, 

dose it send out right data?

 

BR

Alice

0 Kudos