LPCXpresso55S69 -Unable to launch Debug session-Awaiting telnet connection to port 3330

cancel
Showing results for 
Search instead for 
Did you mean: 

LPCXpresso55S69 -Unable to launch Debug session-Awaiting telnet connection to port 3330

111 Views
Contributor I

Hello,

Awaiting telnet connection to port 3330 - Followed all threads based on this issue but nothing worked. Updated firewall, LPC script, etc. Kindly guide.

I am using LPCXpresso55S69 for our project and  I am unable to open debug session wherein console window throws me below message,

MCUXpresso IDE RedlinkMulti Driver v11.1 (Dec 4 2019 18:54:35 - crt_emu_cm_redlink build 5)
Found chip XML file in C:/Users/xyz/Documents/MCUXpressoIDE_11.1.0_3209/workspace2/LPC55S69_Project/Debug\LPC55S69.xml
Reconnected to existing LinkServer process.
Using memory from core 0 after searching for a good core
processor is in secure mode
debug interface type = Cortex-M33 (DAP DP ID 6BA02477) over SWD TAP 0
processor type = Cortex-M33 (CPU ID 00000D21) on DAP AP 0
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 6BA02477. CpuID: 00000D21. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FE000: CID B105100D PID 0000095000 ROM (type 0x1)
ROM 1 E00FF000: CID B105100D PID 04000BB4C9 ROM (type 0x1)
ROM 2 E000E000: CID B105900D PID 04000BBD21 CSt ARM ARMv8-M type 0x0 Misc - Undefined
ROM 2 E0001000: CID B105900D PID 04000BBD21 CSt ARM DWTv2 type 0x0 Misc - Undefined
ROM 2 E0002000: CID B105900D PID 04000BBD21 CSt ARM FPBv2 type 0x0 Misc - Undefined
ROM 2 E0000000: CID B105900D PID 04000BBD21 CSt ARM ITMv2 type 0x43 Trace Source - Bus
ROM 1 E0040000: CID B105900D PID 04000BBD21 CSt type 0x11 Trace Sink - TPIU
NXP: LPC55S69
DAP stride is 1024 bytes (256 words)
Inspected v.2 On chip Flash memory using IAP lib LPC55xx.cfx
Image 'LPC55xx Dec 2 2019 18:56:54'
Opening flash driver LPC55xx.cfx
Sending VECTRESET to run flash driver
Flash variant 'LPC55xx (608KB)' detected (608KB = 19*32K at 0x0)
Closing flash driver LPC55xx.cfx
Connected: was_reset=true. was_stopped=false
Awaiting telnet connection to port 3330 ...

Thank you.

Aishwarya

0 Kudos
3 Replies

28 Views
Contributor I

Hello Jun Zhang,

1- I think it is 1B.

2- Yes, I have connected the board and debugged my existing project before but unable to do it now. It was working fine for a long time, but suddenly it has stopped working. With SDKs, the debugging sessions and other projects debugging session work fine. 

3-Yes, I have tested it on another PC. My teammate also is facing the same issue.

4- I created a  workspace, it doesn't launch debug session and throws the abovementioned error. 

5- I think I have tried only cmsis-dap.

Thank you.

0 Kudos

28 Views
NXP TechSupport
NXP TechSupport

Aishwarya

I confused with one of your comment " With SDKs, the debugging sessions and other projects debugging session", does it means the problem is only in one project and it work well with other 55s69 project?

or you mean it can't connect 55s69 board for any SDK project but connect well with other MCU project?

anyway, I suggest you test the connection in ISP mode.

if this is a common issue for all 55s69 sdk project, please update the firmware with LPCScrypt 2.1.1

https://www.nxp.com/design/microcontrollers-developer-resources/lpc-microcontroller-utilities/lpcscr...

please make sure the version is 2.1.1, I ever has customer meet 55s69 1B connection problem, only LPCScrypt 2.1.1 can fix his connection issue.

Have a nice day,

Jun Zhang

0 Kudos

28 Views
NXP TechSupport
NXP TechSupport

Hi,

TO solve your problem, we needs to know, 

1. your chip version: 0A or 1B?

2. have you ever connected the board once before? if yes, what did you do with the last connection?

3. how does it work if you test it on another PC? 

4. how does it work if you test the connection with creating a new workspace?

5. did you try both cmsis-dap and jlink interface for connection?

Thanks,

Jun Zhang

0 Kudos