LPC54618 Main Clock issue

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC54618 Main Clock issue

198 Views
Contributor I

Good mornig,

I use LPC54618J512 with MCUXpresso IDE V11.1 & Configuration Tool. Using the CAN peripheral, I noted a difference between the bps nedeed (and calculated) and the bps output from peripheral. Using the CLKOUT pin to see the main clock, I see a difference between the PLL_CLK source and the MAIN_CLK source. The PLL_CLK and MAIN_CLK are configure like in the attached picture.

Well, while selecting PLL_CLK as CLKOUT souce, the frequency is correct (after divisor = 1MHz), selecting MAIN_CLK source, frequency output is about 850KHz. For this reason I must modify the CAN bps generator registers to output che correct bps (250kpbs).

What's wrong?

Many thanks in advance for every response.

Best regards, Marco DB

Labels (1)
0 Kudos
6 Replies

16 Views
NXP TechSupport
NXP TechSupport

Hello, Marco

Sorry for the late response. I will test the issue and then let you know my findings.

Have a great day,
Diego.
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello,  m.dibiaggio@agricolmeccanica.it

Update, by now I´ve measured constantly 1 MHz from the CLKOUT pin  main_clk or  pll_clk  as an input signal for the CLKOUTSELA mux.  This by trying to replicate your clock configuration attached, which was very useful to me.

 

 Could you tell whether I´m missing something out (in my clock configuration), or provide me more information to reproduce the conditions that you had? I´m still working to find out the issue.

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time

0 Kudos

16 Views
Contributor I

Hello Diego,

many thanks for your reply.

Please find in attach my oscilloscope screenshots for CLKOUT and the second part of clocks scheme for your test.

NB: In oscilloscope images, SYS_PLL refers to PLL_CLK

Best regards,

Marco

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello Marco

 

I didn't mention that  I was using the LPCXpresso54618 (OM13094) to do my testing, what about you? Are you using a custom board?

 

Do you have another board available to recreate the condition?

 

 The Sys Osc we have selected, through SYSPLLCLKSEL mux,  is an external oscillator. It is possible

For you to select fro_12M instead of Sys Osc and repeat the test? This to help us to identify whether the

problem is related to external hardware or is related to the  MCU itself.


Have a great day,
Diego

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

16 Views
Contributor I

Hello Diego,

thanks for reply.

I use a custom board, based on LPCXpresso54618 schematic. The picture in attach shows frequencies with FRO_12M clock source. The output is the same as with external oscillator SYS_OSC. If it can be useful to analyze the problem, in attach please find clock_config.c source.

Best regards,

Marco DB

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello, Marco

Sorry for my late response, thank you for doing the test with the FRO_12M clock source and providing me with your clock configuration file, it was very useful, but unfortunately, I have not been able to replicate the issue with the MAIN_CLK, because I´m still measuring 1MHz through CLKOUT pin when MAIN_CLK is the input of the CLKOUTSELA mux.  

Do you have an LPCXpresso board available to replicate this on your side? 


Have a great day,
Diego

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos