LPC54018/OM40003 will not flash. CPU will not halt.

Showing results for 
Search instead for 
Did you mean: 

LPC54018/OM40003 will not flash. CPU will not halt.

Contributor II

I'm having a problem with my OM40003 LPC54018 board "right out of the box".  Using MCUxpresso and Link2,

it complains that it cannot stop the processor and never starts loading flash.  I started this question in the

MCUxpresso part of this forum.  Unfortunately, suggested solutions have not worked.  Thought I would try this group for

any additional pointers.  Not trying to "flood" the forum - apologies if this goes against forum rules; but since I

can't load or execute anything on the board, I'm pretty much stuck at this point.  Original post is below. Any

pointers would be appreciated.  Not to belabor the point, I've attempted to debug multiple demo programs that

all built w/o errors and, since flash loading never initiates, I believe the processor is, internally,  still in its "production"

configuration.  IDE builds for LPC55S69 board (with appropriate SDK loaded) work w/o any problems..........


Just received a lpc54018 eval board with LCD (OM40003).  It powers up with the LCD color draw demo - which works

fine.  Have installed latest MCUxpresso and verified that it works by debugging code on a LPC55S69 board to be used

for the same project.  Also loaded the correct SDK for this board and built (no errors) several LPC54018  projects.


When attempting to debug any of the successfully build demo projects (e.g. both littlevgl demos from the SDK), I get the



MCUXpresso IDE RedlinkMulti Driver v11.1 (Feb 24 2020 13:54:38 - crt_emu_cm_redlink build 11)
Found chip XML file in C:/Users/mcp/Documents/MCUXpressoIDE_11.1.1_3241/GStest_54018/lpcxpresso54018_littlevgl_terminal/Debug\LPC54018.xml
Reconnected to existing LinkServer process.
Using memory from core 0 after searching for a good core
On debug connection - use system reset, stalling when 0x40000040 is accessed
Retask read watchpoint 1 at 0x40000040 to use for boot ROM stall
Waiting for target to stop...
Warning - processor did not halt - gave up waiting
debug interface type      = Cortex-M3/4 (DAP DP ID 2BA01477) over SWD TAP 0
processor type            = Cortex-M4 (CPU ID 00000C24) on DAP AP 0
number of h/w breakpoints = 6
number of flash patches   = 2
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 2BA01477. CpuID: 00000C24. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Enabled.
Content of CoreSight Debug ROM(s):
RBASE E00FF000: CID B105100D PID 04000BB4C4 ROM (type 0x1)
ROM 1 E000E000: CID B105E00D PID 04000BB00C Gen SCS (type 0x0)
ROM 1 E0001000: CID B105E00D PID 04003BB002 Gen DWT (type 0x0)
ROM 1 E0002000: CID B105E00D PID 04002BB003 Gen FPB (type 0x0)
ROM 1 E0000000: CID B105E00D PID 04003BB001 Gen ITM (type 0x0)
ROM 1 E0040000: CID B105900D PID 04000BB9A1 CSt TPIU type 0x11 Trace Sink - TPIU
ROM 1 E0041000: CID B105900D PID 04000BB925 CSt ETM type 0x13 Trace Source - Core
NXP: LPC54018
DAP stride is 4096 bytes (1024 words)
Inspected v.2 External Flash Device on SPI LPC540xx_SPIFI_SFDP.cfx
Image 'LPC540xx_JEDEC_SFDP Feb 17 2020 13:57:06'
Opening flash driver LPC540xx_SPIFI_SFDP.cfx
Using SOFT reset to run the flash driver
rst - Boot ROM stall address was not accessed (but we entered debug on Halt anyway)
Cannot halt processor
warning - failed to halt processor on startup timeout - rc Ep(04). Cannot halt processor.
Flash Driver V.2 startup failed - rc Ef(34): Timed-out initializing flash.
chip initialization failed - Ef(34): Timed-out initializing flash.
failed to initialize flash driver LPC540xx_SPIFI_SFDP.cfx


Have searched this site for similar issues and have tried restarting with several alternate configs -

namely with and without J5 (DFU boot) inserted and powering up with any of the ISP buttons

depressed. I can get the board to start up w/o the demo executing, so I assume I have started in the ISP

code.  Flash erase using the IDE behaves similarly.  As the saying goes - "no joy".  I don't think I could

have possibly bricked the board since it never gets to loading any code...besides, none of the

demos are related to OTP.  As I pointed out above, this environment works fine with Link2 on a current

LPC55S69 board.


Any help getting past this would be appreciated. 



Chuck McP

View the message

This email was sent by NXP Community because you are a registered user.
You may unsubscribe instantly from NXP Community, or adjust email frequency in your email preferences

Labels (1)
Tags (1)
0 Kudos
2 Replies

Contributor II

Yes and Yes.  I've tried it with JP5 in and out, in ISP mode and with the IDE flash tool.  Same results.

Others have asked about similar issues; but these have all been related to loading user modified code.

This board fails with all the 54018 demos I have built (0 errors)......I've tried at least 6 examples.  As previous

email  describes, flash driver never gets past initialization.  Is the code for flash downloading available? I

could start digging into it....


0 Kudos

Senior Contributor IV

Are you using the on-board Link2 or and external Link2? Have you followed the instructions in 3.2 (Starting a debug session using the on-board (Link2) Debug Probe) of the User Manual?

0 Kudos