Compatibility issues with LPC54018 DFP and Keil MDK

cancel
Showing results for 
Search instead for 
Did you mean: 

Compatibility issues with LPC54018 DFP and Keil MDK

135 Views
Contributor II

I'm evaluating the LPC54018 to use in a product. I purchased the LPC54018 IoT Board to use a development board and I'm using Keil MDK for my development environment. I started with one of the example projects (hello_world) but ran into compiler/linker issues.

I found that when using Keil MDK 5.29, the examples compile and run correctly.

However when using Keil MDK 5.30 or newer, the examples do not compile.  I eventually found this technical note from Keil which documents the issue:

ARMCLANG: Pre-processing of assembler file in armclang 

I tried the suggested workaround with Keil MDK 5.30 and the project compiles successfully!  However after flashing the firmware to the target board, I found that the firmware does not actually run as expected.  In fact, it doesn't seem to execute at all, from what I can tell.

So my questions, is anyone else dealing with this problem? Have you identified any fixes?

I am going to continue pursuing this issue, and I have tickets open with Keil and NXP support to aid in my troubleshooting.  Hopefully we'll get to the bottom of it sooner rather than later.

Labels (1)
0 Kudos
1 Reply

95 Views
NXP TechSupport
NXP TechSupport

Hello Greg Straka,

I have reply you on Salesforce, it can work well on my side.

If still have question, please contact me.

Regards,

Alice

0 Kudos