CAN baudrate settings

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

CAN baudrate settings

794 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by Linas on Thu Oct 04 06:08:31 MST 2012
Hello,

I am trying to configure CAN on the LPC1769. I am using LPCxpresso board and attached SN65HVD23 (CAN transceiver).

External oscillator for CPU clock is 12 MHz.

For CAN configuration and messages handling I am using CMSIS driver for CAN interface. My system is running at 48 MHz and

clock for CAN peripheral is 48 MHz/2 = 24 MHz. So, the issue is that CAN is working at 125 Kbps. But once I set it at 250

Kbps, 500 Kbps CAN do not work. I can't receive any messages. In my project I will need a wide range of CAN baud rates (1

Mbits/s, 500 Kbits/s, and etc.).

Maybe there are some considerations regarding CAN clock settings?


Best regards,

Linas
Labels (1)
0 Kudos
Reply
4 Replies

744 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by Linas on Thu Feb 21 08:35:47 MST 2013
Also, I can give other advises. You could enable CAN error interrupts in case of wrong baudrate, short lines issue in CAN bus. This also helps to find out some problems.

Linas
0 Kudos
Reply

744 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by Linas on Thu Feb 21 08:33:27 MST 2013
Hi,

I am using PEAK-CAN board to test CAN communications with my board. I forgot to put 120 Ohms resistor in parallel.

So, that's why didn't work CAN communications at higher baud rates (250, 500 and etc.).


Best,

Linas
0 Kudos
Reply

744 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by hua on Tue Feb 19 19:35:04 MST 2013
I configure the baudrate at 500kbps and i couldn't receive data,either. Can you help me or tell me your problem.
0 Kudos
Reply

744 Views
lpcware
NXP Employee
NXP Employee
Content originally posted in LPCWare by Linas on Fri Oct 05 04:56:14 MST 2012
I have found the problem. So everything works correctly.
0 Kudos
Reply