LwIP stuck in netconn_new

cancel
Showing results for 
Search instead for 
Did you mean: 

LwIP stuck in netconn_new

689 Views
danielpedersen
Contributor I

Hello Freescale. Been working with K64F devel board and TCPECHO + FreeRTOS example (sdk 1.3.0). I have sat all buffer sizes, priorities and stack sizes to match requirements but after a few hours (not always same (time/packet amount/reconnect amount), just within 5 hours) netconn_new hangs.

 

I am running code with multiply checks to avoid any error doing runtime, so the netconn interface from code level is not wrong (everything is freed/deleted). The code work as a TCP client that connect up towards a server (netconn_new), send a bashful of data (netconn_write/recv), netconn_close/netconn_delete, waiting 30 seconds and do the same again.

netconn_new never simply never returns after using netconn_new and netconn_delete for a few hours. Tried both internal pools and MALLOC interface. No change.

Anyone experience same issue or maybe got a fix?

Labels (1)
Tags (2)
0 Kudos
1 Reply

193 Views
ivadorazinova
NXP Employee
NXP Employee

Hi Daniel,

I apologize for the late response. Please, is the issue still actual for you?

Please, do you use FRDM-K64F or TWR-K64F?

I tried on my side with FRDM-K64F, for example demo TCP Echo Demo on lwIP TCP/IP Stack and it works without problems.

It works as TCP server. Procedure for starting demo is described in KSDK 1.3 Demo Applications User´s Guide

In case of TWR-K64F please be careful about correct set jumpers for 50MHz.

Thank you.

Best Regards,

Iva

0 Kudos