KDS 3.0 and KSDK 1.3 Eclipse Update

cancel
Showing results for 
Search instead for 
Did you mean: 

KDS 3.0 and KSDK 1.3 Eclipse Update

3,875 Views
anthony_huereca
NXP Employee
NXP Employee

Hello KDSK and KDS users!

There's been some reports of issues after updating KDS 3.0 with the KSDK 1.3 Eclipse Plugin. You may get the following error when debugging using CMSIS-DAP/OpenOCD or JLink:

95962_95962.pngkds-error.png

"An internal error occurred during "Launching hello_world_frdmk64f debug cmsisdap". ilg.gnuarmeclipse.debug.gdbjtag.dsf.GnuArmServicesFactory <init>(Ljava/lang/String;Ljava/lang/String;)V"

 

 

The reason this occurs is when the KSDK 1.3 Eclipse Update is installed on a fresh KDS 3.0 installation, KDS also asks to update several other components during the update install process. Unfortunately two of those debugging components that are updated cause the debugger to stop working as they conflict with other components of KDS. If you already see this issue on your computer, the work-around is to over-write those two debugger components with their original versions, which can be found in the plugins.zip file Erich Styger provided in this thread: Re: Unable to Debug after KDS Update 

 

 

 

However to avoid this issue in the first place, use the Help->"Check for New Updates" menu to ONLY update the Processor Expert for Kinetis item. That's the only required component, and the most important thing is that the debugging components aren't updated.

96384_96384.PNGkds-select - Copy.PNG

 

and then install the KSDK_1.3.0_Eclipse_Update.zip (as described in the Getting Started with Kinetis SDK Guide in Section 5.2) afterwards.

95970_95970.PNGksdk13.PNG

 

 

So the steps would be:

1) Install KDS 3.0

2) Go to Help->Check for New Updates

3) Only select the Processor Expert for Kinetis item to update it to 3.0.1

4) Finish the Update process

5) Install Kinetis SDK 1.3

6) Install the KSDK 1.3.0 Eclipse Update.zip (using the steps described in Section 5.2)

 

Regards,

Anthony

Labels (1)
Tags (3)
3 Replies

321 Views
liuxing_hu
Contributor II

1. I can't reach the page  Getting Started with Kinetis SDK Guide in Section 5.2, the link is invalid

2.where can I find KSDK_1.3.0_Eclipse_Update.zip?

0 Kudos

308 Views
liuxing_hu
Contributor II

thank you very much for  your reply

but I think I made a mistake, I'm using s32ds for ARM, you are using Kinetis Design Studio IDE (KDS IDE), so I think that we are talking different thing.

have you used s32ds for ARM?

if have, when I open a project created by s32ds 2018 using s32ds 2.2, the error happened, can refer to attachment, can yo deal with it?

that's why I search about Kinetis informantion.

0 Kudos