Problem Using KMS with Custom Board

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Using KMS with Custom Board

578 Views
PedroCastro
Contributor III

Hi everyone,

I have been using KMS 1.2 succesfully with my FRDM-KV31 and also using the generated code in MCUXPresso for my own application.

However, I have now my custom board, using KV31, that I program with my PEMicro Multilink FX and it turns out that I cannot use KMS GUI with the programmer. Is there a way to use it? What would be a workaround to set the parameters?

Thanks!

Labels (1)
0 Kudos
5 Replies

224 Views
philip_drake
NXP Employee
NXP Employee

For the Evaluation boards The KMS GUI communicates during commissioning through the OPENSDA UART bridge built into the evaluation board. 

In the design of your custom board did you make any provisions to connect a PC UART to one of the boards uarts? or any other communications port?

If you did not then you need to somehow connect a PC's serial interface TX and RX pins to the MCU.   If your design is similar to the FRDM-MC-LVPMSM and FRDM-KV31 combo then you don't have issues with voltage isolation like on the HVP motor driver implementation.

I've done this a couple of ways. 

The FRDM-KV31F board could  be used if you connected to the right node of the board along with V target and ground.   So if you created a cable to go from the FRDM-board to your custom board you would use the virtual serial port of the FRDM board to communicate with the target MCU.

FRDM-KV31_UART_IF.png

FRDM-KV31_UART_IF_atMCU.png

Another way is to use a TWR-SER card.  I power up the card with a primary elevator and connect to the target TX, RX and GND pins, assuming the TARGET is at 3.3 V VDD.

I would connect TXD to Pin 1 of J19 and RXD to pin 1 of J17.

TWR-SER_UART_IF.png

 

Let us know how you end up solving this.

Regards,

Philip

0 Kudos

224 Views
PedroCastro
Contributor III

Hey Philip, thanks for your reply!

Here is what I did:

I used an frdm-kv31f as a SWD programmer. I tested uploading a program through MCUXPresso and also loading applications from the KMS interface. However, the serial communication does not work. My board uses PTA14 and PTA15 as UART0. The default pins used by the generated code from KMS are PTB16 and 17. I tried to modify these settings in saved projects by hand and upload the new firmware, but once again unsuccessfully. Do you have any other suggestions?

0 Kudos

224 Views
philip_drake
NXP Employee
NXP Employee

I see from your other post that you are now communicating.  Is that Correct?  Either way let us know.

Philip

0 Kudos

224 Views
PedroCastro
Contributor III

No! From the other post I am using a frdm-kv31f to do some testing

0 Kudos

224 Views
philip_drake
NXP Employee
NXP Employee

The UART connections change from the default pin to alternate pins are mentioned in the Adapting KMS for Custom Hardware.  However the steps you need to take to make this change are left to your own skills. I have published on another post these steps linked here.   Please review these steps and you should be able to get it to work.

Philip

0 Kudos