regarding PE Micro Universal Multi-link

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

regarding PE Micro Universal Multi-link

963 Views
aratisood
Contributor I

Hello , My question is regarding PE Micro Universal Multilink. We have developed a Board based on FRDMK64F. And using PE Micro multilink .. All of a sudden the Multilink has stopped working and no link on the USB led. What could be the reason and how to repair this issue. Any help will be greatly appreciated. I had only one PE Micro and our development is suffering. Also if there is a cheaper alternative to  PE Micro Universal Multilink please suggest.

0 Kudos
4 Replies

843 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Arati,

If you have Freedom Board with Segger OpenSDA Debug Firmware, it can be used to debug your custom board.
Have you try to update the firmware of USB Multilink? You can download "USB Multilink Universal (and FX) Resource CD" from PE micro.
Does this USB Multilink work on other computer?

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

843 Views
aratisood
Contributor I

Hi Robin,

Thank you for your reply.. I am not directly the developer ... but I know in the original FRDMk64f board we were using segger for debug but in the Custom board that interface has been used for some other purpose.. though I am not 100% sure. We will try the firmware update also ..the issue itself is very strange ... if we disconnect the PE Micro multilink for a hour or so the USB light switches on for 1-2 mins and then again goes off . 

Thanks again

Arati.

0 Kudos

843 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Which PORT of USB Multilink Universal are used to connectted K64?

Please also show us the debug port circuit of K64.

USB Multilink Universal PORT.jpg

Best Regards,

Robin

0 Kudos

843 Views
aratisood
Contributor I

Hi Robin,

Sending you a photo of our custom Board, 

But the problem is with the USB Multilink not the board .. because the USB led on the USB Multilink is not glowing anymore so it seems to be a power supply or some other h/w issue

Meanwhile I have written to PE Micro tech support also ..according to then it is some h/w issue on the USB ML..Hopefully they will also help us..

Thanks again

0 Kudos