Trouble waking KL03 using 10-bit I2C in VLPS mode

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble waking KL03 using 10-bit I2C in VLPS mode

607 Views
kyledickerson
Contributor I

I am having difficulty getting a KL03 slave to wake up from VLPS mode when using 10-bit I2C.  The microcontroller wakes up just fine on address match in 7-bit I2C.  I also have communication working using 10-bit I2C in VLPR mode.  The IAAS interrupt fires using the 10-bit/VLPR, 7-bit/VLPS, and 7-bit/VLPR, but not 10-bit/VLPS.  Is 10-bit I2C not available in VLPS mode?  Or is there something else that needs to be done to get it to work.  Thanks! 

Labels (1)
0 Kudos
2 Replies

440 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Kyle Dickerson,

   From the reference manual description:

pastedImage_1.png

It just describes the primary address, no extended address, maybe it doesn't support the 10 bit wake up, but is not sure, I didn't test it before.

You can send me your test project, when I have time, I will also check it on my side. After reproduce it, I will check it with our according department.

Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

440 Views
kyledickerson
Contributor I

Unfortunately I am unable to send you my project.  My workaround is to set the KL03 slaves to 7-bit addressing, then have them switch to 10-bit addressing on wakeup.  I only have KL03 slaves on the bus so this shouldn't be an issue.  If I have the maximum of 1024 slaves on the bus, the worst that will happen is that at most, 8 slaves will be awake for a very brief time.

0 Kudos