Not able to connect with MKE15Z using J-Link

cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to connect with MKE15Z using J-Link

294 Views
xpress-embedo
Contributor III

Hi All,

I am new to NXP and Cortex based Micro-controllers, and working on a project.
Everything was working fine, but I think I messed up a setting in the project and due to which I am not able to connect with my board.

The board is based on the MKE15Z256VLH7 micro-controller. It was working fine without any problem but suddenly after some changes in the code, it stopped working.

I am not sure, but it looks like that I accidentally change the Pin Mux associated with the RESET pin.

By Default PTA5 is RESET_b and I changed it to ALT_0 (As per datasheet, nothing is present on this setting), by mistake, this is done.

Is there, anyway, I can program and debug my board again.

I tried to connect using J-Link commander, the following is the scenario I am getting.

SEGGER J-Link Commander V6.54c (Compiled Nov 7 2019 17:01:56) DLL version V6.54c, compiled Nov 7 2019 17:01:02

Connecting to J-Link via USB...O.K. Firmware: J-Link V9 compiled May 17 2019 09:50:41 Hardware version: V9.30 S/N: XXXXXXX License(s): GDB VTref=4.616V

Type "connect" to establish a target connection, '?' for help J-Link>connect Please specify device / core. <Default>: MKE15Z256XXX7 Type '?' for selection dialog Device>MKE15Z256XXX7 Please specify target interface: J) JTAG (Default) S) SWD T) cJTAG TIF>S Specify target interface speed [kHz]. <Default>: 4000 kHz Speed>1000 Device "MKE15Z256XXX7" selected.

Connecting to target via SWD InitTarget() Connect Under Reset Communication error while accessing MDM-AP. Connect Under Reset InitTarget() Connect Under Reset Communication error while accessing MDM-AP. Connect Under Reset

****** Error: InitTarget(): PCode returned with error code -1

InitTarget() Connect Under Reset Communication error while accessing MDM-AP. Connect Under Reset InitTarget() Connect Under Reset Communication error while accessing MDM-AP. Connect Under Reset

****** Error: InitTarget(): PCode returned with error code -1

Cannot connect to target. J-Link>

I even tried with MKE15Z256XXX7 (ALLOW SECURITY), but still, it didn't connect.

With IAR I am getting this error now. (As I am not able to connect)

Controller Problem.PNG

Some few additional points:

* RESET pin is pulled high in hardware using 10k resistor.

* I already tried a basic/simple program, to turn on the led, and I have the same problem now with all projects.

Please let me know if some more information is required from my side.

Reset Circuit is as below.

Reset.PNG

Please suggest.

Thanks in advance.

Labels (1)
Tags (2)
0 Kudos
1 Reply

177 Views
Omar_Anguiano
NXP TechSupport
NXP TechSupport

Hello xpress-embedo

 

It seems that your kinetis is blocked, I suggest you refer to this post Communication error while accessing MDM-AP.  in order to unlock your micro.

 

Please let me know if the suggestion is helpful,

Best regards,

Omar

0 Kudos