MKL03 in-software flash programming

cancel
Showing results for 
Search instead for 
Did you mean: 

MKL03 in-software flash programming

Jump to solution
327 Views
Contributor II

Hello,

I'm trying to re-flash few sectors of MKL03 internal flash in software.  When I run the flash_example out of the SDK1.3 example drivers, the flash sectors are programmed correctly.  However, when I add the flash component to my project through Processor Expert, and I try to use the same logic as the example, the desired sectors are not being flashed.  I already checked that the flash configuration is done correctly and my FlashCommandSequence function is relocated to RAM, but its execution does not change the content of the flash.  Are there any other settings (power, clk, etc.) that I need to change in order to get the re-flashing working?

Thank you

1 Solution
13 Views
Contributor II

Jingjing,

I was able to resolve my issue.  In addition to disabling global interrupts, I had to re-configure my my clock configuration with proper Bus/Flash clock.  Once I had the clock correct, I was able to in-software program the internal flash.

Thank you for your help

View solution in original post

5 Replies
13 Views
NXP TechSupport
NXP TechSupport

Hi Artur,

    You can't write the data to the flash, did you meet any problem when debug it?

      Did you disable the interrupt before you do the flash operation?

    You can refer to this post at first, make sure you disable the global interrupt:

https://community.nxp.com/message/597793

    The code you can refer to the KSDK1.3.0 flash demo.

    If you still have question, please contact me!


Have a great day,
Jingjing

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
14 Views
Contributor II

Jingjing,

I was able to resolve my issue.  In addition to disabling global interrupts, I had to re-configure my my clock configuration with proper Bus/Flash clock.  Once I had the clock correct, I was able to in-software program the internal flash.

Thank you for your help

View solution in original post

13 Views
Contributor IV

Please,can you specify wich are the right and the bad clock configurations?Thanks

0 Kudos
13 Views
NXP TechSupport
NXP TechSupport

Hi Diego,

   If you have the KL03 problem, please create your own question post, we will help you in your own post.


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
13 Views
Contributor IV

Thanks Kerry Zhou,

i already did it but i 'm even more confused 
https://community.nxp.com/thread/478394 
Best regards
Diego

0 Kudos