MCUXpresso IDE Exception , Probe not open while trying to debug with FRDM-KW36

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCUXpresso IDE Exception , Probe not open while trying to debug with FRDM-KW36

1,699 Views
123gmax
Contributor II

Hello,

         While trying to debug application in FRDM-KW36, I am frequently getting exception as shown in below screenshot

123gmax_0-1602791231434.png

Some time if I change the USB port then I can establish the debug session with the target but sometime it requires the reboot of the computer. 

I do experience that in between debug session an error message as show below will pop-up sometime

123gmax_1-1602791374788.png

What could be the issue? Any help to resolve this is greatly appreciated. 

Note : I am interfacing KW36Z chip as SPI slave with another board (MCP2210 module as master) with below pin in FRDM-KW36. Will this cause any problem?

PTA18 -> SCLK
PTA17 -> MOSI
PTA16 -> MISO
PTA19 -> CS

 

Thanks,

Labels (1)
0 Kudos
4 Replies

1,436 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi @frank-li2021 

  Please create the new question post about your KW36 question in this area:

https://community.nxp.com/t5/Wireless-Connectivity/bd-p/wireless-connectivity

 Then our wireless engineer will help you, I am mainly provide service for RT series now, thanks so much for your understanding.

Best Regards,

Kerry

0 Kudos

1,440 Views
frank-li2021
Contributor III

frankli2021_0-1632710888810.pngfrankli2021_1-1632710901617.pngfrankli2021_2-1632710909849.png

 

@kerryzhou Hi Kerry please have a look on my reply thanks lot

@123gmax have you resolved the problem now?

0 Kudos

1,688 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi 123gmax

  If you don't connect your FRDM-KW36 board to the other board, whether you have the debug issues or not? You can run the SDK code for the FRDM-KW36 directly in the MCUXpresso IDE, any debug issues, or just your own code and connect with the external boards?

   What's the onboard debugger you are using now? CMSIS DAP or the JLINK?

    When you connect the FRDM-KW36 to the other board, whether the two boards are using the same power supply, do you connect the GND together or not?

 

Please help to check the above points at first.

Wish it helps you!

If you still have questions about it, please kindly let me know!

Best Regards,

Kerry

-------------------------------------------------------------------------------

Note:

- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored

Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

-----------------------------------------------------------------------------

0 Kudos

1,466 Views
frank-li2021
Contributor III

I got the same error.

I'm using micro-usb for power supply and openSDA to debug the KW36 board

IDE mcuXpresso can probe the cmsis-dap, but show err msg as below

Unable to open probe index 1.
Error: Probe not open


Unable to open probe index 1.
Error: Probe not open

Error: Probe not open

at com.nxp.mcuxpresso.core.debug.support.linkserver.redlink.client.RedlinkServerClient.checkServerReply(RedlinkServerClient.java:214)
at com.nxp.mcuxpresso.core.debug.support.linkserver.redlink.client.RedlinkServerClient.openByIndex(RedlinkServerClient.java:740)
at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.ideConnect(AbstractJtagDiscovery.java:205)
at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.connect(AbstractJtagDiscovery.java:187)
at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.discover(AbstractJtagDiscovery.java:146)
at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.TargetDiscovery.jtagDiscovery(TargetDiscovery.java:457)
at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.getEmulatorInfo(LaunchScriptUtils.java:248)
at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.init(LaunchScriptUtils.java:488)
at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.<init>(LaunchScriptUtils.java:156)
at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.<init>(LaunchScriptUtils.java:143)
at com.nxp.mcuxpresso.core.debug.support.linkserver.services.TargetDiscoveryService.getTargetDiscovery(TargetDiscoveryService.java:138)
at com.nxp.mcuxpresso.core.debug.support.linkserver.override.LSFinalLaunchSequence$TargetDiscoveryJob.run(LSFinalLaunchSequence.java:110)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

Tags (1)
0 Kudos