KL82Z - PORTD interrupt in PEX

cancel
Showing results for 
Search instead for 
Did you mean: 

KL82Z - PORTD interrupt in PEX

Jump to solution
106 Views
Contributor III

I am trying to figure out where to enable the PORTD interrupt via Processor Expert.  I inherited a project (originating from the SDK demos) where only PORTA and PORTC are enabled currently.

As shown in the attached screenshots, everywhere I've located so far has the option disabled and it cannot be modified.

Surely PORTD can be utilized for interrupts on the KL82Z?  Is this a bug with the "Kinetis SDK 1.3.0 Standalone for KL82Z" package possibly?

Labels (1)
1 Solution
20 Views
NXP TechSupport
NXP TechSupport

Hi Nick Bedbury,

Please select generate code for PORTD IRQ handler first.
Then you can see the PORTD Interrupt enabled.

generate code PORTD IRQ handler.png

PORTD Interrupt enabled.png

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

3 Replies
21 Views
NXP TechSupport
NXP TechSupport

Hi Nick Bedbury,

Please select generate code for PORTD IRQ handler first.
Then you can see the PORTD Interrupt enabled.

generate code PORTD IRQ handler.png

PORTD Interrupt enabled.png

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

20 Views
Contributor III

Thanks Robin.  I think there was some glitch in the Linux KDS IDE.  I re-opened the project in the IDE in Windows and was able to select "Generate Code" under the Events tab like you showed.  In Linux, this was also a read-only setting.

0 Kudos