K22F - Ef(49) error.

cancel
Showing results for 
Search instead for 
Did you mean: 

K22F - Ef(49) error.

284 Views
can_pouliquen
Contributor II

Hello,

I recently started working on a FRDM-K22F and started an empty project from scratch.

I configured the MCU settings according to the example projects of the SDK.

Everything went well for a few hours, the project was building and debugging normally. But the next morning, debugging wasn't functionning anymore, neither for my own project nor even for the SDK's example projects ! The green led indicating connexion with the debugger isn't lighting up (D1 led).

I keep having following error whenever I want to debug :

"EraseSector (0x800, 0x0, 0x1) status 0x1 - driver reported driver error - INTKFMM driver rc 16 - Flash protection violation
Sectors written: 1, unchanged: 1, total: 2
Closing flash driver FTFA_2K.cfx
Target error from Commit Flash write: Ef(49): Flash driver operation gave error."

I have already tried mass erasing the Flash or resurrecting a locked device, but nothing did the trick. I really have no idea where the problem could be comming from as, once again, everything was behaving properly just the day before.

If you have any idea on how to solve the problem, I would gladly welcome any help. Thank you in advance !

Here are the MCU settings I set up :

Flash driver : FTFA_2K.cfx

Flash location : 0x0 - size : 0x80000

Upper RAM location : 0x20000000 - size : 0x10000

Lower RAM location : 0x1fff0000 - size : 0x10000

Labels (1)
0 Kudos
1 Reply

275 Views
myke_predko
Senior Contributor III

Hi @can_pouliquen 

Could it be that you have updates that are waiting to install in your system?  I find that when Windows is waiting on an update it causes all sorts of unrelated mayhem, especially with IO.  

Have you tried disconnecting your FRDM-K22F, closing MCUXpresso IDE and then doing any pending updates?  Even power cycling your PC could be helpful.  

Good luck!

myke

0 Kudos