How to configure the FreeMASTER serial driver in FRDM-KV31F platform?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to configure the FreeMASTER serial driver in FRDM-KV31F platform?

957 Views
albertobisutti
Contributor I

Hi guys,

I'm trying to include FreeMASTER serial driver in a project for FRDM-KV31F development board.

I got the source and header files from FreeMASTER_Serial_Communication_Driver_V2.0 installation folder, but what I would like to understand is which serial communication peripheral should I use?

I mean, should I use the UART0 that connetcs the KV31 to the OpenSDA interface or should I use the SWD interface?

Thanks for the support.

Alberto

0 Kudos
6 Replies

613 Views
miduo
NXP Employee
NXP Employee

Hello,

You can using P&E OpenSDA to connect the FRDM-KV31F board.

pastedImage_3.png

pastedImage_2.png

0 Kudos

613 Views
albertobisutti
Contributor I

Hi Fang,

I write here again because I'm still facing some issues with FreeMaster settings.

After using BDM communication as you suggested in your reply I was able to make run Scope.

Now I'm trying to use Recorder, so I call the FMSTR_Recorder(); function iniside my ISR but when I try to run a recorder from FreeMaster application I get the below reported message

pastedImage_1.png

Actually I configured FreeMaster to use the LPUART (#define FMSTR_USE_LPUART 1), but considering that I'm using the BDM communication plug-in I also tried to select Packet Driven BDM communication interface setting #define FMSTR_USE_PDBDM        1, but this change seems to have no impact on FreeMaster behaviour.

As well as using the LPUART the scope keeps working but I'm not able to make run the recorder.

To try to give you some more information I also attach the recorder properties window, where you can see that FreeMaster is not able to get the board time base for example, even if in my code I set it as 100us with this macro #define FMSTR_REC_TIMEBASE    FMSTR_REC_BASE_MICROSEC(100)

pastedImage_5.png

Have you got any idea about how can I fix this issue?

Thank you in advance.

Alberto

0 Kudos

613 Views
miduo
NXP Employee
NXP Employee

Hello,

Sorry this post been left open. Please let me know if this issue still exist or not?

0 Kudos

613 Views
albertobisutti
Contributor I

Hi Fang,

actually I fixed the issue setting #define FMSTR_USE_PDBDM  1 and assigning the right address in the Packet Buffer Address box.

pastedImage_1.png

With this configuration everything works properly.

 

0 Kudos

613 Views
miduo
NXP Employee
NXP Employee

Hello, Alberto

It is great !  Thanks for sharing out what you had done! I am pretty sure it is much helpful!

0 Kudos

613 Views
albertobisutti
Contributor I

Hi,

I just try it and it worked immediately!!!

Thank you very much!!

Alberto

0 Kudos