FRDM-KL25Z - problem with connecting to computer

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM-KL25Z - problem with connecting to computer

9,236 Views
moonlightlane
Contributor I

Hi,

I just started using this board, and I have problem at the beginning - I cannot connect the board to the computer. The SDA connector works fine, and the program pre-installed on the board (LED intensity changes by sliding the capacitor) also works. But it does not work when I connect the other USB to the computer. Instead of giving me a file disk named "BOOTLOADER", it shows nothing; and the device manager shows me an unrecognizable device "USB UART".

Does someone know what problem I have encountered? I spend almost two hours trying to figure out this seemingly simple problem. Thanks!

Labels (2)
Tags (3)
11 Replies

1,623 Views
perlam_i_au
Senior Contributor I

Antonio exactly describe what you should do in order to use your freedom, I just like to include a note, when you want to load the OpenSDA drivers or flash your board remember to use the USB connector named "SDA"

openSDA.JPG.jpg
Have a nice day :P,
Perla

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct/Helpful Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

1,623 Views
AndrejBarbis
Contributor I

Hi,

I have a similar problem -> when i push reset and try to connect the device to bootloader mode, i can not see it in explorer. In device manager is assigned as unknown usb device?

Thank you

Regards

Andrej

0 Kudos

1,623 Views
perlam_i_au
Senior Contributor I

Do you keep pressed Reset until the green led start to blink?

0 Kudos

1,623 Views
AndrejBarbis
Contributor I

Well, to describe a problem a little more. When i first plugged the device to the computer, i was able to access to files on device, even bootloader. But after that i reseted computer, and every time from there i am not able to see driver in device manager. LED diode is changing color from blue to red. It is possible that files from bootloader has gone? i ve also install PE driver but the device is not recognizable any more.Yes, nothing happens if i keep pressed RESET.

Regards

Andrej

0 Kudos

1,623 Views
perlam_i_au
Senior Contributor I

Please go to this thread and download the guide mentioned, review instructions on page 5, here you will find what to do to reinstall the drivers you need

How to load code(binary code) into KL25 and make it run out of reset w/o debugger connection?

In the page 6 you will find again the instructions to enter bootloader and Load application modes.

You can check in which mode you are looking on your device name on the explorer:

Bootloader mode:

bootloadermode.JPG.jpg

Load application mode:

Loadapplicationmode.JPG.jpg

0 Kudos

1,623 Views
zero
Contributor I

I've got the same problem as the original poster in regards to not being able to see the bootloader in windows 7.

I've completed the following steps:

I downloaded the quick start package.

I went to P&E Microcomputer Systems and installed the drivers for SDA.

I've read over the quick start guide a few times, especially pages 5 & 6. I can't get past page 5 because after I have the drivers installed, it doesn't matter which combination I use to try and see the bootloader, it doesn't show up in my explorer window. I have been plugging the usb cable into the SDA connection port.

No matter what I do I am not getting anything recognized as far as I know. I do hold in the switch before plugging it into usb and no matter how long I hold it nothing happens, no green LED blinking, no activity at all. When I release the button it powers on and  enters the default program which changes the LED based on position and utilizes the capacitive slider as a fader. I don't see anything changing in my device manager whether it's plugged in or not. The Jungo branch has only WinDriver underneath it's directory.

I have software named driver suite v10.4 installed.

I went to the link you posted How to load code(binary code) into KL25 and make it run out of reset w/o debugger connection? but if I'm not mistaken this information is all one big loop. Everything seems to be based on that this device should be able to be recognized and change modes from bootloader to load application modes and should also show a different designation for each mode. So would this mean that my device is defective if it can't access any of the flash memory? Any ideas as to how that would possible not to be able to access the flash memory when the loaded program is on that drive and is working normally?

0 Kudos

1,623 Views
perlam_i_au
Senior Contributor I

I would like to confirm with you in order to verify if this problem is only for your device, please just check on the list below:

  • You have downloaded and installed P&E drivers, right?
  • When you connect your FRDM-KL25Z miniUSB OpenSDA to the USB port of your computer you see a MSD device called FRDM-KL25z, here you can see some files (those files could be HTML, HTM, CAT, INF or TXT), correct?
  • Then you disconnected the board, press RESET (not just pres and release the button, keep press RESET) and connect again to the PC, here I would like to know, does the small led next to the reset button blinks?

Please confirm with me this information and then we will proceed to check the other parts, could you reach the last step I mentioned?

0 Kudos

1,623 Views
zero
Contributor I

Thank you for replying!

I've solved the problem by simply changing the cable for a new one!

I tried to return and reply that I solved that issue but couldn't find my way back. Hahahha. I think I'm going to spend a few days reading and then ask a question if I have any.

Thanks again for your help, very much appreciated.

1,623 Views
perlam_i_au
Senior Contributor I

Well I am very happy to know this was solved :smileygrin:!!

Have a nice day!!

0 Kudos

1,623 Views
quevedo
Contributor V

Hello,

I see you expected to see a flash disk named BOOTLOADER. This is not what is expected to happen when you plug the board. This flash drive shows up if you enter bootloader mode. For this, you must keep RESET button pressed while plugging the board.

However, BEFORE you do anything else, you should install the FRDM drivers so your computer will recognize all FRDM enumerated devices (it is trying to install the USB COM port with no success). You should access:

http://www.pemicro.com/opensda/index.cfm

and download the "Windows USB Drivers". Run the EXE file and the drivers will be installed.

Your board may come with the latest firmware installed. If that is the case, after you install the drivers and plug the board (WITHOUT pressing RESET), your computer should install and register three devices:

1. A flash drive named KL25Z. This disk can be used to flash a BIN or HEX file directly into the target processor. It is quite useful if you use mbed, because you get a BIN file when you compile a project. If that is the case, you just drag and drop this BIN file into that flash disk and then it is up and running.

2. An OpenSDA debugger channel. To see this, you must go to your computer's device manager and look for JUNGO drivers, and inside this category you will find your debugger channel.

3. A COM port over USB. Also, check your computer's device manager, under "Ports" category.

Some boards may not come with the debugger or the flash disk (they always come with COM port). If that is the case you may update your firmware, downloading the "OpenSDA Firmware (MSD & Debug)" at the same page mentioned above. Unzip the file and look for the correct firmware update (the one with KL25 in its name). For updating the firmware, you keep RESET button pressed while plugging the board on your computer. With the drivers already installed, soon you will see the BOOTLOADER drive. Just drag and drop the correct firmware file to this drive and wait for it to load (green LED flashing; when it stops, your firmware is updated). Just unplug and plug it again, and you should have your 3 USB devices installed.

I hope it helps

Good luck and Cheers

1,623 Views
moonlightlane
Contributor I

Yes thanks I think I got it! The fact that there are two usb ports on the boards confuses me a little bit. What I did before was, I connect SDA port to PC, and press RESET while connecting the other usb port on the board to PC, and sure enough, nothing happened. The correct way to do is just press RESET while connect the SDA port to PC.

So when do I use the other "normal" USB port on the left? Will I ever use it? I guess all of the development process, like loading stuff into the board, should be done with the SDA port?

Thank you so much for this exhaustive and detailed response!!

0 Kudos