FRDM KL25Z has stuck to "Programming..."

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM KL25Z has stuck to "Programming..."

937 Views
Eric_t
Contributor III

Hi everybody,

I have just received the FRDM KL25Z board.

Since the board comes with no debugger, I tried to drag & drop pemicro SDA debugger into FRDM board. Accidentally I drag & drop a wrong file (I even do not remember what file).

Now LASTSTAT.TXT file says “Programming”

As far as I know it should say “Ready” or something similar.

Neither codewarrior nor KDS is able to connect with KL25Z board.

They cannot even see the SDA debugger. Probably it is expected since the SDA debugger is not present in FRDM KL25Z board.

Also cut the line at J11 jumper and I solder a connector to J6-SWD.

I create a project for kl25z with KDS and I tried to connect with multilink universal.

At a point KDS upgrade the firmware of multilink universal. Then there was messages like “target programming”, “target program”, “target verified”, “cannot enter background mode” (I do not remember exactly).

Unfortunately no luck with multilink universal.

Is there a way to recover SDA debugger of my FRDM KL25Z board?

May be if LASTSTAT.TXT go away from “Programming” the FRDM KL25Z board be recovered.

Thank you

5 Replies

229 Views
Eric_t
Contributor III

Erich Styger and Jorge Gonzalez,


Thank you for your help.

For some reason I had misunderstood the role of J11 jumper.

I solder it and now multilink universal is able to connect with FRDM KL25Z board.


Alexandre Byshimo,

Indeed SDA debugger did not work because of the win 8.1.

I have updated the SDA debugger using a win7 PC and now everything is working fine on windows 8.1


Thank you



229 Views
alexandrebyshim
Contributor II

I had exactly the same problem when I was using my windows 8 PC. And then I followed the step by step instructions posted by Jorge_Gonzalez but this time using a windows 7 PC and I was able to update the new bootloader and the MSD - DEBBUG my Frdm-kl25z. Now everything is working fine even on windows 8. Thanks Jorge_Gonzalez

229 Views
Eric_t
Contributor III

When I use KDS and multlink universal I get the following messages:

P&E GDB Server, Version 5.13.02.00

Copyright 2014, P&E Microcomputer Systems Inc, All rights reserved

Loading library C:\Freescale\KDS_2.0.0\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_1.1.8.201411191655\win32\gdi\unit_ngs_arm_internal.dll ... Done.

Command line arguments: -device=KL25Z128M4 -startserver -singlesession -serverport=7224 -interface=USBMULTILINK -speed=5000 -port=USB1 -USE_CYCLONEPRO_RELAYS=0 -FORCE_MASS_ERASE=1

Device selected is kl25z128m4

User Specified Hardware Selection : Interface=USBMULTILINK and Port=USB1

Connecting to target.

P&E Interface detected - Flash Version 6.10

Can not enter background mode  .

Unable to initialize PEDebug.

PE-ERROR: Failed to Initialize Target

Server running on 127.0.0.1:7224

Connection from "127.0.0.1" via 127.0.0.1

PE-ERROR: Target is not connected

Disconnected from "127.0.0.1" via 127.0.0.1

Target Disconnected.

Any ideas?

Thank you

0 Kudos

229 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Eric_t d:

J11 must not be removed, that is the connection for KL25 SWD_CLK signal pin. Please first resolder J11 or place a solder joint. Then you should be able to program with the Multilink.

For OpenSDA, if it still does not work, follow the procedure in the next tutorial by colleague Erich Styger:

Illustrated Step-by-Step Instructions: Updating the Freescale Freedom Board Firmware | MCU on Eclips...


Regards!,
Jorge Gonzalez

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

229 Views
BlackNight
NXP Employee
NXP Employee

To program the board with the Mutlilink on J6, have J11 jumpered (not open) and the board powered through the SDA USB plug.

Erich

0 Kudos