FRDM-K64F losing program after power off

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM-K64F losing program after power off

401 Views
jasondark
Contributor I

I am using the FRDM-K64F for a senior design project. I am programming the controller using KDS and processor expert by way of OpenSDAv2 from the segger website. I am programming the microcontroller with low level components instead of using the specified freedom board library. When I disconnect the board after debugging, the program only works until it loses power a second time. Any idea why it will not stay programmed indefinitely?

0 Kudos
8 Replies

133 Views
giacomopetrini
Contributor IV

I had this kind of problem when using the default bootloader (from mbed.org).
Installing the JSegger bootloader solved the problem. And it is also much faster.

Best Regards

Giacomo

0 Kudos

133 Views
jasondark
Contributor I

I thought I was using the segger loader, do you have a link to the one you are using? It's from the segger website I assume.

0 Kudos

133 Views
BlackNight
NXP Employee
NXP Employee

There is an option in the Processor Expert (CPU component) to disable EZPORT:

pastedImage_0.png

You could give that one a try.

Erich

0 Kudos

133 Views
jasondark
Contributor I

I tried this.. it still would not solve the problem.

0 Kudos

133 Views
Amit_Kumar1
Senior Contributor II

Hi Jason

In the selected processor expert component can u check if u have selected Flash or RAM for coding. By default the processor expert selects RAM so In that case, it can erase the program on POR. Try selecting Flash .Hope it helps

Regards

Amit

0 Kudos

133 Views
Hui_Ma
NXP TechSupport
NXP TechSupport

Hi Jason,

Does that issue be fixed? What's your FRDM-K64F board hardware version?

Please check the FRDM-K64f board errata file.


Have a great day,
Ma Hui

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

133 Views
BlackNight
NXP Employee
NXP Employee

I'm aware of a booting problem with the EZPORT enabled. Maybe this is your issue?

See

FW does not run without SW1 reset after PowerOn

FRDM-K64F booting issue when powered from USB port

Erich

0 Kudos

133 Views
jasondark
Contributor I

After reading through the past threads, it is possible to make a software fix for this, correct? My question, is it as simple as changing a value in the flash configuration settings (per a reply to "FRDM-K64F booting issue when powered from USB port") or do I need to mess with the NMI and have it setup something (also mentioned in the post) Right now, I took all of the button inputs and used them for test inputs, thus disabling the NMI; however, enabling the NMI is not an issue, I guess I just do not fully understand what should be my end goal. Should I just read up more on the EZPORT mode in the reference manual?

0 Kudos