FRDM K64F UART Logical levels

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM K64F UART Logical levels

Jump to solution
202 Views
Contributor I

Hi everyone,

I got a noob question about the FRDM k64f  board :

I'm trying to set a RS232 communication with another device using UART2, the chars are well sent but the logical levels are weird : on my scope the high level of my data is about 500mV. Shouldn't it be 3.3V ?

Regards,

Martin

0 Kudos
1 Solution
28 Views
NXP TechSupport
NXP TechSupport

Hi Martin,

    I think you also need to check your scope and probe configuration, you can test the on board fixed 3.3.V, is that correct on your scope?


Have a great day,
Jingjing

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
29 Views
NXP TechSupport
NXP TechSupport

Hi Martin,

    I think you also need to check your scope and probe configuration, you can test the on board fixed 3.3.V, is that correct on your scope?


Have a great day,
Jingjing

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
28 Views
Contributor I

Yeah my scope and probe configuration are correct and the 3.3V is ok on my board(s).

Sending 'ESC' char  at 115200 bauds :

commandeESC.png

I am going to test Mark Butcher's firmware right now to see what happens.

Thanks for your replies.

Martin

0 Kudos
28 Views
Specialist V

Hi

Are you sure you haven't connected the RS232 transceiver incorrectly (driving the UART2_TX line)?

If you want to check with a firmware which correctly drives the UART2_TX output, load the binary "USB-CDC with 5 UARTs" at http://www.utasker.com/kinetis/FRDM-K64F.html

You can then perform VCOM to UART bridges to all of the K64's UARTs to test yours (UART2_TX on PTD3) and any other UARTs that you may need.

Regards

Mark

0 Kudos