Custom Board based on K60 tower regarding ethernet issue

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Custom Board based on K60 tower regarding ethernet issue

Jump to solution
1,028 Views
khoanguyen
Contributor I

Hi,

My project includes creating a custom board with ethernet and ADC functionality, with MQX 3.8.1, CW 10.2, and the k60 tower development.

So far the custom board has been successful with all but the ethernet transceiver. We've chosen the same ethernet transceiver on the K60 dev kit, but we're now at a standstill on what could be going wrong since we followed the schematics and double checked them.

The custom board is able to have code flashed onto and run successfully on MQX demos, except for any ethernet required demos. When an ethernet cord is plugged into the custom board and a computer, neither of the lights are on so there is no connection, but I'm assuming this is a hardware problem.

I was wondering if this could be a hardware problem or software problem? Do the BSP/PSP config files have to be reformatted to the custom board, even though it works with the MQX ADC demo using the kinetis bsp/psp files?

Thanks,

Khoa Nguyen

0 Kudos
1 Solution
681 Views
Luis_Garabo
NXP TechSupport
NXP TechSupport

Hi Khoa,

This sounds to be a hardware issue with your PHY. One thing that you can verify is the layout guidelines for Ethernet. This application notes includes those guidelines for any microcontroller or microprocessor in the chapter 8: http://cache.freescale.com/files/32bit/doc/app_note/AN4215.pdf

If you are using the same PHY you then should be able to work with the MQX examples provided for Ethernet. In such case, that points to be a hardware issue.

Have a nice day!

-Garabo

View solution in original post

0 Kudos
2 Replies
682 Views
Luis_Garabo
NXP TechSupport
NXP TechSupport

Hi Khoa,

This sounds to be a hardware issue with your PHY. One thing that you can verify is the layout guidelines for Ethernet. This application notes includes those guidelines for any microcontroller or microprocessor in the chapter 8: http://cache.freescale.com/files/32bit/doc/app_note/AN4215.pdf

If you are using the same PHY you then should be able to work with the MQX examples provided for Ethernet. In such case, that points to be a hardware issue.

Have a nice day!

-Garabo

0 Kudos
681 Views
edgarsevilla
Contributor II

I have a similar problem:

Problem to change transceiver (LAN8710A)


I have access to PHY, but there is no comunication.

Is any other way to test it?

Regards,

Edgar Sevilla

0 Kudos