Task aware debugging installation issue

cancel
Showing results for 
Search instead for 
Did you mean: 

Task aware debugging installation issue

684 Views
Contributor III

Seeing an issue with the new views after installing the task aware plugin via the http://freescale.com/lgfiles/updates/Eclipse/KDS  update site on KDS 3.2.0 on Mac
155236_155236.pngScreen Shot 2016-07-06 at 10.29.44 AM.png

 

My installation details:

155270_155270.pngScreen Shot 2016-07-06 at 10.35.39 AM.png

Labels (1)
Tags (1)
9 Replies

16 Views
Contributor I

Hi,

I too am interested in a fix for this on Linux.

cheers john

0 Kudos

16 Views
Contributor IV

unfortunately the problem keeps existing even if i install kds 3..2.0 and install all the available updates.

I'm running this on a linux host (RedHat Enterprise 6.7)

kds_freertos.png

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello Peter ,

Do you use the root privileges when installing new plugins ?

pastedImage_0.png

Or please check this thread to have a try :

https://mcuoneclipse.com/2015/06/15/workaround-for-installing-software-has-encountered-a-problem-in-...

BR

Alice

0 Kudos

16 Views
Contributor IV

yes I was running KDS with root privilges.

it's not the installation that is failing, its the display of the views the plugin provides.

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello Peter and Jacob,

I have reported this issue to KDS team ,  i will reply you .ASAP when i got the result .

Hope it helps

ALice

16 Views
Senior Contributor II

Hi,

Same for me, with fresh install of KDS 3.2.0 on ubuntu 16.04 LTS (x86_64).

Thread debugging works fine, Task/Queues/Timers/Heap windows display the error message, and freeRTOS menu do nothing (even "About freeRTOS TAD" item).

Best regards,

Emmanuel

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello All ,

Sorry reply you so late , the KDS team expert reply as below :

"Bug was in wrong translation of icon's path on unix based systems caused by hardcoded backslash in an icon path.
Fix will be released in FreeRTOS TAD v1.0.1
"

BR

Alice

16 Views
Contributor IV

I'm having the same isse, but I'm still at KDS 3.0.0. An update might fix the problem

0 Kudos

16 Views
NXP TechSupport
NXP TechSupport

Hello Jacob,

Could you please install all of the update in KDS, then restart it to have a try.

If still can not work , please re-install the KDS, then install the update to have a try.

BR

ALice

0 Kudos