Possible Conflict Between KDS PE and RM

cancel
Showing results for 
Search instead for 
Did you mean: 

Possible Conflict Between KDS PE and RM

706 Views
Contributor III

I believe that I have found a conflict between the KDS PE error checking for component pin use and the Reference Manual for at least the K21 chip. In the RM for the K21 subfamily (Number: K21P121M120SF5RM attached), section 3.7.1.4.1, the chart lists pin ADC1-DP0 as a possible single-ended pin for ADC input. However, in the attached image, KDS (version 1.0.1) reports a hardware error if this pin is configured in this way. A similar error occurs for pin ADC1-DP1. This conflict likely exists for the K22 chip, although KDS has not been tested for this case. Curiously, the error does not occur when the ADC1-DP0 pin is used by ADC0 (This pin is weaved with ADC0-DP3). Between the conflicting behavior in KDS and the RM, I believe this to be a bug. Let me know if any more information is needed.

Labels (1)
0 Kudos
4 Replies

5 Views
NXP Employee
NXP Employee

Hi Joseph,

Sorry for delay.

Based on KDS 1.0.1 I've created a project for MK21FN1M0.

Then I added the ADC_LDD bean.

It seems I'm able to select ADC1_DP0/ADC0_DP3 for channel 1.

Attached you will find my example code.


Have a great day,
Pascal

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

5 Views
Contributor III

The difference between my configuration and yours is that your is set to use ADC0, and mine to ADC1. I'm not sure why, but ADC1_DP0/ADC0_DP3 can be used as a singled ended measurement for ADC0, but not ADC1. Also this does not address the same error that occurs for ADC1_DP1 (See attached image).

0 Kudos

5 Views
NXP Employee
NXP Employee

Hi Joseph,

I will check with Processor Expert team.

Keep you informed.


Have a great day,
Pascal

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

5 Views
NXP Employee
NXP Employee

Hi Joseph,

Sorry for the delay.

With Processor Expert team we've investigated the problem.

This is a common problem under KDS, Driver suite and MCU v10.6 products.

There are two missing vectors in CPUDB.

The problem will be solved in next version of tools.

DriverSuite V10.4.1 and KDS release planned this summer will solve the problem.

Thanks for doing our product better.

Have a great day,
Pascal

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos