How to add Processor Expert to a KSDK example project?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to add Processor Expert to a KSDK example project?

362 Views
nícolasludwig
Contributor II

Hello everyone.

First of all, I tried to follow steps on this link:

Adding Processor Expert to C Project (with SDK in PEx Driver Suite) 

And also follow the Help Contents on Kinetis Design Studio in "Adding Processor Expert Project to an Existing Project".

I was trying to add Processor Expert to the bubble_level_tpm example project from FRDM-KL27Z folder.

Everything worked fine until the build time.I did all the steps as it should be done, but in the end I got some erros. The errors are in the images below.

error 1.png

error 2.png

error 3.png

I posted my entire project and the Console window on Google Drive, in the links below:

bubble_level_tpm.zip - Google Drive 

console.txt - Google Drive 

 

I'm using KDS 3.0.0, KSDK 1.3.0 and Windows 7.

My platform is the FRDM-KL27Z.

 

What can I do to fix it?

Thanks for any help!

0 Kudos
3 Replies

120 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Nícolas Ludwig ,

Please first build KSDK platform library in KDS IDE.

About the detail steps you can refer to :

"Getting Started with Kinetis SDK (KSDK) v.1.3.pdf"  -> 5.3 Build the platform library

Hope it helps

Alice

0 Kudos

120 Views
nícolasludwig
Contributor II

Hi Alice_Yang‌.

I did it, and I also put the necessaire paths in settings of my project, and then the errors appears.

Thanks and I await.

0 Kudos

120 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello ,

 - I  test on my side , after fixed this error , there will be others.

It needs much time , we might as well create a proejct based on PE, then copy the application code into it.

also your proejct just a simple demo code , it is more easy than adding PE to project.

- And the Guide you mentioned just a general guide , there will be defferent build error for defferent project.

- The KSDK1.x is old , If you just started development , I recommend you use the latest version KSDKv2.x.

BR

Alice

0 Kudos