FRDM-K64F OpenSDA Debugger Problem

Showing results for 
Search instead for 
Did you mean: 

FRDM-K64F OpenSDA Debugger Problem

Contributor II


I am trying to configure an OpenSDA debugger probe in KDS 3.0 to load my application to a FRDM-K64F development board.  When I go to the configuration screen and select "OpenSDA Embedded Debug", I have no options under the port dropdown.  


From referencing this NXP post: OpenSDA Serial and Debug Adapter | NXP , I have tried setting my board into bootloader mode by holding the reset button down as I attach my USB cable.  On the first startup, it was enumerated as MAINTENANCE.  Once the drivers were installed by Windows, the name of the device changed to DAPLINK.  Following the flow chart presented in step 1. on the linked page, I tried to drag and drop the latest firmware bin file onto the board, and it disconnects and reconnects with the following three files:  


The details file lists the following:  


and the NEED_BL file shows this:


When I try reloading the bootloader by disconnecting, holding down the reset button and reconnecting, the drive re-enumerates as DAPLINK and the same three files are present.  

I am wondering what my next steps should be, as it appears that I cannot load any firmware onto my development board, but it does not appear to be "bricked" by the standards listed in the flowchart in page I linked above.  I contacted NXP support through their online chat and was directed to post here in order to receive a response from an engineer.  

Thanks for your help with this matter, 

#kds-3.0#bootloader frdm k64f#daplink#opensda#nxp_support‌ 

Labels (1)
4 Replies

NXP TechSupport
NXP TechSupport


Only when it was mounted as "maintenance", you drag the firmware to it . 

And if it can not be mounted as "maintenance", it will be fixed after you re-download the opensda's bootloader to it via a j-link . 


Have a great day,


- If this post answers your question, please click the "Mark Correct" button. Thank you!


- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos

Contributor II

Thank you for your reply, Jianyu, 

I have a J-Link base model, which does not have a license for using J-Flash.  Is using J-Flash to load the bootloader firmware my only option for repairing the firmware on my FRDM-K64F board?  

0 Kudos

Senior Contributor III

Hi Carson,

First: you only need a J-Link to reprogram the board if you bricked it (e.g. always in maintenance mode).

And you can use the JLinkLite.exe instead of the JFlash.exe.

I recommend you load the SEGGER J-Link OpenSDA v2.0 firmware on your board, see Segger J-Link Firmware for OpenSDAv2 | MCU on Eclipse .

If you are using Windows 10: be aware of Recovering OpenSDA Boards with Windows 10 | MCU on Eclipse and in case of an emergency How to Recover the OpenSDA V2.x Bootloader | MCU on Eclipse .

I hope this helps,


0 Kudos

Contributor II

Thanks Erich, I intended to reply to this a few weeks ago but it slipped my mind.  

For future readers, although my board was not "bricked" in the sense that NXP or Erich describes, using JFlashLite to load the SEGGER J-Link OpenSDA firmware was successful and has solved my problem.  

Thanks to everyone who responded for their help.