freemaster connection problem

cancel
Showing results for 
Search instead for 
Did you mean: 

freemaster connection problem

Jump to solution
227 Views
Contributor I

I'm working on a new 24V BMS design. For development, the FRDM33771BSPIEVB together with the S32K144EVB-Q100 are used, as recommended by Tomas Vaverka(NXP employee). Currently there is a problem that the FreeMASTER visualization tool is not communicating with the S32K, error: "Can not detect the board information! The communication will be paused. Error code: 0x80000101 (Response timeout.)" There are threads on the forum which discussed the same problem, but the url’s to the solutions were all not working. Can you help out to solve this problem?

0 Kudos
1 Solution
53 Views
NXP Employee
NXP Employee

The fact that the RED pin is turned on and it never hits the Poll functions means that the application enters on the else branch (line 1253) of the if  statement (line 1209). FreeMASTER Driver routine is never executed on the target side thus the timeout error on the PC side - the requests from the desktop application never reach the embedded code.

main.c

initialization part

Capture3.PNG

...main loop & FreeMASTER Driver execution are skipped...

Capture4.PNG

I would suggest to debug those 3 function calls inside the if clause: BCC_MCU_ConfigureLPSPI, BCC_Init & FMSTR_Init.

Regards,

Iulian

View solution in original post

0 Kudos
10 Replies
53 Views
NXP Employee
NXP Employee

Dear Wim, can you tell more about the way you are trying to connect? 

It is probably one of:

  • Serial line emulated using USB virtual serial line implemented in the on-board debugging probe
  • Direct serial line to S32K processor
  • CAN connection
  • BDM/JTAG direct memory access connection. 

In the first three cases: is FreeMASTER driver part of your S32K application and is it configured for the selected communication (serial or CAN)? If not, then you should still be able to connect using BDM/JTAG direct access. Is your on board debugging interface programmed with the CMSIS-DAP, J-Link or P&E Micro firmware?

You can try using the Connection Wizard in FreeMASTER to see if it helps you to find the correct settings.  

Thanks,

Michal

0 Kudos
53 Views
Contributor I

Dear Michal,

The S32K development board is connected by USB, and the development board is connected by SPI to the MC33771 development board. The S32 development suite is programmed with the PE Micro firmware. The connection wizard has been used, but this does not help.

In addition: jumper resistors have been re-soldered to according to the attached picture.

The S32K MCU is flashed with the FreeMaster Example project, by using S32 design studio for ARM(2018.R1).

When starting debugging, it inserts a breakpoint in main.c at line 1172: CLOCK_SYS_Init (g_clockManConfigssarr, CLOCK_MANAGER_CONFIG_CNT

Is this normal behavior? The FreeMaster pdf file doesn’t mention this.

I hope that you can give some hints how to bring up the connection.

With kind regards,

Wim van der Steeg

Field Application Engineer

Avnet Silica

Stadionstraat 2, 6th floor

4815 NG Breda

The Netherlands

O +31.0.76.572.23.52

M +31.0.6.538.515.70

F +31.0.76.572.27.07

<https://plus.google.com/+Silica_Avnet>[http://digital.avnet.com/signature/images/avnet_facebook-20.png]<https://www.facebook.com/silica.avnet>[http://digital.avnet.com/signature/images/avnet_twitter-20.png]<https://twitter.com/AvnetSilica>[http://digital.avnet.com/signature/images/avnet_linkedin-20.png]<https://www.linkedin.com/company/silica-an-avnet-company>[http://digital.avnet.com/signature/images/avnet_youtube-20.png]<https://www.youtube.com/user/SILICAMarcom>

avnet-silica.eu<http://avnet-silica.eu/>

<https://www.avnet.com/wps/portal/emea/about-us/avnet-emea/business-updates/coronavirus/>

0 Kudos
53 Views
NXP Employee
NXP Employee

Hello Wim,

I'm sorry I do not know the MC33771 add-on board, and I can only give general answers or hints:

  • The behavior when program execution stops at the entry point (first line of main()) after loading is normal.
  • FreeMASTER has nothing to do with a debugger. So you will not find any breakpoint-related or any other debugger-related information in FreeMASTER documentation.
  • FreeMASTER can only connect to a running application - so you need to resume application execution after it stops in the main() function.
  • I assume you are trying to connect over serial line - so are you sure the application is running (resumed from breakpoint)? Also, can you send me the screenshot of the Connection Wizard window with detected COM ports? And a screenshot of the connection error? 
  • In case you are trying to connect over JTAG/BDM plug-in, please be aware that you need to abort the debugging session first. The P&E Micro probe must NOT be occupied by a debugger when connecting with FreeMASTER. This is why connecting over serial line makes more sense as you can have both debugger and FreeMASTER running. (on the other hand, connecting over JTAG/BDM is easier as you do not need to have the freemaster serial driver in the MCU application).

If neither of the hints above helps you to get it up and running, please send me the example application that you are trying to run. ZIP the whole project and send it here as an attachment.

Thanks,

Michal

0 Kudos
53 Views
Contributor I

Dear Michal,

Attached you can find screenshots of the error message and settings.

These screenshots are made after resuming the application, so it is running.

When the connection wizard is used to connect (option ‘’use direct connection to on-board usb port’’ or ‘’use plain old serial line or USB to serial converter cable’’), the error is different and it states: ‘’no board detected on any of specified UART communication ports.’’

The S32K board via the on-board usb-b connector to the laptop usb port is used to connect.

I do not know about JTAG/BDM and neither the um11143 nor the freemaster application pdf guide mention anything about it.

Again, thanks for your help.

With kind regards,

Wim van der Steeg

Field Application Engineer

Avnet Silica

Stadionstraat 2, 6th floor

4815 NG Breda

The Netherlands

O +31.0.76.572.23.52

M +31.0.6.538.515.70

F +31.0.76.572.27.07

<https://plus.google.com/+Silica_Avnet>[http://digital.avnet.com/signature/images/avnet_facebook-20.png]<https://www.facebook.com/silica.avnet>[http://digital.avnet.com/signature/images/avnet_twitter-20.png]<https://twitter.com/AvnetSilica>[http://digital.avnet.com/signature/images/avnet_linkedin-20.png]<https://www.linkedin.com/company/silica-an-avnet-company>[http://digital.avnet.com/signature/images/avnet_youtube-20.png]<https://www.youtube.com/user/SILICAMarcom>

avnet-silica.eu<http://avnet-silica.eu/>

<https://www.avnet.com/wps/portal/emea/about-us/avnet-emea/business-updates/coronavirus/>

0 Kudos
53 Views
NXP Employee
NXP Employee

Hi WimvanderSteeg‌,

I looked for the application and other discussion you mentioned. Just as Michal I'm not familiar with it but I did a quick check on FreeMASTER setup in BCC SW Driver package for MC33771B/MC33772B (Lite version) and can confirm that it is correct. I suspect a harware issue, so here are a few steps that could help identifying it: 

1. As per this comment - is the RED LED turned on after you flash the application ?

2. Can you put a break point inside the main loop on FreeMASTER Pool function (FMSTR_Pool inside main.c line 1222) to check whether it is ever reached ?

3. Could you flash an S32K144 example application from S32DS.ARM.2018R1 (minimal FreeMASTER setup):

File → New  S32DS Project from Example  filter "freemaster_s32k144"

Kind regards,

Iulian

0 Kudos
53 Views
Contributor I

Dear Iulian,

To answer your questions:

1. Yes the RGB LED lights up after flashing the freemaster application

2. When a breakpoint is placed at line 1222, and pressing resume (f8) after it has stopped at the function breakpoint at line 1172, it just keeps running without stopping. Though a check mark does appear at the set breakpoint (line 1222). See the picture (attached).

3. “freemaster_s32k144” is flashed and after launching freemaster it connects without a problem, see picture for running application (attached).

So my guess is that something is wrong with the Free|Master example project for the S32K in combination with the MC33771 development board. What would be the next step of determining the problem?

Regards, and thanks,

Wim van der Steeg

Field Application Engineer

Avnet Silica

Stadionstraat 2, 6th floor

4815 NG Breda

The Netherlands

O +31.0.76.572.23.52

M +31.0.6.538.515.70

F +31.0.76.572.27.07

<https://plus.google.com/+Silica_Avnet>[http://digital.avnet.com/signature/images/avnet_facebook-20.png]<https://www.facebook.com/silica.avnet>[http://digital.avnet.com/signature/images/avnet_twitter-20.png]<https://twitter.com/AvnetSilica>[http://digital.avnet.com/signature/images/avnet_linkedin-20.png]<https://www.linkedin.com/company/silica-an-avnet-company>[http://digital.avnet.com/signature/images/avnet_youtube-20.png]<https://www.youtube.com/user/SILICAMarcom>

avnet-silica.eu<http://avnet-silica.eu/>

<https://www.avnet.com/wps/portal/emea/about-us/avnet-emea/business-updates/coronavirus/>

0 Kudos
54 Views
NXP Employee
NXP Employee

The fact that the RED pin is turned on and it never hits the Poll functions means that the application enters on the else branch (line 1253) of the if  statement (line 1209). FreeMASTER Driver routine is never executed on the target side thus the timeout error on the PC side - the requests from the desktop application never reach the embedded code.

main.c

initialization part

Capture3.PNG

...main loop & FreeMASTER Driver execution are skipped...

Capture4.PNG

I would suggest to debug those 3 function calls inside the if clause: BCC_MCU_ConfigureLPSPI, BCC_Init & FMSTR_Init.

Regards,

Iulian

View solution in original post

0 Kudos
53 Views
Contributor I

Hi Iulian,

Thanks for the suggestion, I think the BCC_init function might be the issue here, as I did not figure out how to configure the bcc_drv_config_t structure (see attachment).

Do you have quick explanation of how to configure this structure?

Thanks and kind regards,

Wim van der Steeg

Field Application Engineer

Avnet Silica

Stadionstraat 2, 6th floor

4815 NG Breda

The Netherlands

O +31.0.76.572.23.52

M +31.0.6.538.515.70

F +31.0.76.572.27.07

<https://plus.google.com/+Silica_Avnet>[http://digital.avnet.com/signature/images/avnet_facebook-20.png]<https://www.facebook.com/silica.avnet>[http://digital.avnet.com/signature/images/avnet_twitter-20.png]<https://twitter.com/AvnetSilica>[http://digital.avnet.com/signature/images/avnet_linkedin-20.png]<https://www.linkedin.com/company/silica-an-avnet-company>[http://digital.avnet.com/signature/images/avnet_youtube-20.png]<https://www.youtube.com/user/SILICAMarcom>

avnet-silica.eu<http://avnet-silica.eu/>

<https://www.avnet.com/wps/portal/emea/about-us/avnet-emea/business-updates/coronavirus/>

0 Kudos
53 Views
NXP Employee
NXP Employee

Unfortunately I cannot help you with that one. But I think there may be people in Sensors space able to assist you.

You can raise a new question there and reference this thread so whoever takes your requests can pick it from here.

Kind regards,

Iulian  

0 Kudos
53 Views
Contributor I

Hi Iulian,

After further inspection, there were some weak solder points on the board. These are repaired, and the system connects and runs as expected.

Thanks for all help and inputs!

Wim van der Steeg

Field Application Engineer

Avnet Silica

Stadionstraat 2, 6th floor

4815 NG Breda

The Netherlands

O +31.0.76.572.23.52

M +31.0.6.538.515.70

F +31.0.76.572.27.07

<https://plus.google.com/+Silica_Avnet>[http://digital.avnet.com/signature/images/avnet_facebook-20.png]<https://www.facebook.com/silica.avnet>[http://digital.avnet.com/signature/images/avnet_twitter-20.png]<https://twitter.com/AvnetSilica>[http://digital.avnet.com/signature/images/avnet_linkedin-20.png]<https://www.linkedin.com/company/silica-an-avnet-company>[http://digital.avnet.com/signature/images/avnet_youtube-20.png]<https://www.youtube.com/user/SILICAMarcom>

avnet-silica.eu<http://avnet-silica.eu/>

<https://www.avnet.com/wps/portal/emea/about-us/avnet-emea/business-updates/coronavirus/>

0 Kudos